summaryrefslogtreecommitdiff
path: root/dev-ml/findlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /dev-ml/findlib
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'dev-ml/findlib')
-rw-r--r--dev-ml/findlib/Manifest2
-rw-r--r--dev-ml/findlib/findlib-1.9.1.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-ml/findlib/Manifest b/dev-ml/findlib/Manifest
index 0d9670b83520..52dc5d4cf602 100644
--- a/dev-ml/findlib/Manifest
+++ b/dev-ml/findlib/Manifest
@@ -1,4 +1,6 @@
AUX externalmeta7.patch 527 BLAKE2B bf4a4aec02096766f9741705fbf99201c742abc992ddb05c143378d7bb6d0b79f3c3541199eb5a81142fa1b317980646c3fe12528f792cbfaa7762f024bd88d1 SHA512 61c1e03e5b0d021f2cd7d013bed54edd610edb48cf9f6c063d3542abea2d2fc811c1cf7284b54a584491064dee8dd4e72656ba90a63c144586f40705b8443a1d
DIST findlib-1.8.1.tar.gz 261544 BLAKE2B acfa9d4e0d118ebbc0dd7b03da1fe5eaa994e5fec13dc54e60ba42f643d93968469a1a43fe4f832433dca6c3902e8846616fcf460c748bf037fe16cb2f93a847 SHA512 0d8e1ff21217fcc6823aab3ac71282789691e4ae8c3607703d0393468247f93e2d084bd4e2a8795b523f2c7f193521d3aae4b8122c934ebf8b58c3185a5bc9c1
+DIST findlib-1.9.1.tar.gz 273012 BLAKE2B 8b51e3ca3dde04e77e225638f9d45166acf42fb1e3321aa5ce6e66fcddcfb978a301f2fa22a26172e1a8c2f8a879c5d1d10e8c984994d6b2879c21c4392955ce SHA512 83a05f3e310fa7cabb0475c5525f7a87c1b6bc2dc5e39f094cabfb5d944a826a5581844ba00ec1a48dd96184eb9de3c4d1055cdddee2b83c700a2de5a6dc6f84
EBUILD findlib-1.8.1-r2.ebuild 1670 BLAKE2B f64382277a45d1cbe278e6eb389cafd2fb255363694b36483b8eef0c33af4f08db95f2ab14b13a02f985c3e8b04940a39cb175616ad9e224893175342ff4be38 SHA512 9c51f008f2a9ee6189ee1a541f8187a149195dd114694ef35cd0c7774bdb128bf32df8a4f8f28dccec656eb8d5540590f24fb458aec84cadb1b04bbededd03fa
+EBUILD findlib-1.9.1.ebuild 1629 BLAKE2B be50bf81301e64b7eebefea1e7ee454f0ff42062bf54621d92f0dd427bcee2f031f743957fff86a1e7a9d5be9075488891a2c39884a60458de5e725edf81f1fc SHA512 e3d9d8083d36446a0ed05fa6cbaf844ccb5c8fec59ff396bca6f9f600a6408c038bdb6693d1b135b4e8ef125f5fcc9f9f0e44583bc768de09fb92b65e6f4ec03
MISC metadata.xml 417 BLAKE2B 2ea51d563846cf4b4a6826678f68a32db60cd0c5174524701e6d91c59c8be896f26b6a7f7ce458b9466424d7325542219c7fb2b59d2114cf2a29a0d8772fe92f SHA512 d4243498f26d7517fd55467382b8968e75e3593f1d3ba76c87cc0a53746e6e500c2bab475e51c9490abccf4ca5044637f681f5b50ad090d72e580eff9358ca6e
diff --git a/dev-ml/findlib/findlib-1.9.1.ebuild b/dev-ml/findlib/findlib-1.9.1.ebuild
new file mode 100644
index 000000000000..4a52a554364a
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.9.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OCaml tool to find/use non-standard packages"
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt tk"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]
+ tk? ( dev-ml/labltk:= )"
+RDEPEND="${DEPEND}"
+
+QA_FLAGS_IGNORED='.*'
+
+src_prepare() {
+ default
+ export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+ export stublibs="${ocamlfind_destdir}/stublibs"
+}
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ if use doc; then
+ cd "${S}/doc" || die
+ dodoc QUICKSTART README DOCINFO
+ docinto html
+ dodoc -r ref-html guide-html
+ fi
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}