summaryrefslogtreecommitdiff
path: root/dev-ml/facile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/facile
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/facile')
-rw-r--r--dev-ml/facile/Manifest4
-rw-r--r--dev-ml/facile/facile-1.1.3.ebuild53
-rw-r--r--dev-ml/facile/files/facile-1.1-make.patch48
-rw-r--r--dev-ml/facile/metadata.xml12
4 files changed, 117 insertions, 0 deletions
diff --git a/dev-ml/facile/Manifest b/dev-ml/facile/Manifest
new file mode 100644
index 000000000000..f22e425c6381
--- /dev/null
+++ b/dev-ml/facile/Manifest
@@ -0,0 +1,4 @@
+AUX facile-1.1-make.patch 1613 BLAKE2B e469aa4820358b9d197251c6b3c6150c0aeaca8362d104441fc35e975e401776e1d23804a160cd6b37c545c769c0c856ff871d0428bbde47828fc9cc79125d20 SHA512 024132dfacce666c1f52f331fe5ec9f927dbabc1742b44aa11be7ae8851c25943afea5f2f99b3e544127b5c49af7d7337d4b59c60165a777990402855100ebc0
+DIST facile-1.1.3.tar.gz 99656 BLAKE2B 19d81c48c39b96083628cc40eb9aca7e8ad7dea4ae81c884bfb22daa56135ac411698d57b68f3112829a1fc53d29612627809901c6e30eb4672776508eee57b2 SHA512 78d315188e661245eb7306b645e9baaca94db0b9511112b57dbc8597bf2f75cab5604c8f4cf850209464e802c636f592552c8b492730cb28896d2acd7f413346
+EBUILD facile-1.1.3.ebuild 1382 BLAKE2B 57bc5e307ef4d3f1e2739a4b424bb5219305652b723a437af6223af852059f1555497b05219b971376578578e85dab3ca55e9bed89eceef7eab83105a325f71c SHA512 c6c7efef6229133f5dd486f15db813ba449fad79fabfc0a51f0c9bb913ba58e6efedfb1fe8933545086605bc5b5477c82e4c2af46db60a90e877d52da6a2893a
+MISC metadata.xml 357 BLAKE2B d06a43a03a328a01985ccb6d8f3c374215a678da2c7019fae195f49d86a55245cbd3fdd4b43641b0b1b92000a9546600451985421551bc1e10239cc4716c9d57 SHA512 8491e3bed96f117fe721e3e6d261d75480e0b183c06ec21d606ccf659263dc8c2642b1fd30f89aec63a2e70a725f71985119117c1c11fa3fe8b49b7c31db969c
diff --git a/dev-ml/facile/facile-1.1.3.ebuild b/dev-ml/facile/facile-1.1.3.ebuild
new file mode 100644
index 000000000000..3027374ee74d
--- /dev/null
+++ b/dev-ml/facile/facile-1.1.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="OCaml constraint programming library on integer & integer set finite domains"
+HOMEPAGE="http://opti.recherche.enac.fr/"
+SRC_URI="http://opti.recherche.enac.fr/facile/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ sys-apps/sed
+"
+
+DOCS=( README )
+
+PATCHES=( "${FILESDIR}/${PN}"-1.1-make.patch ) # Fix building on FreeBSD
+
+src_prepare() {
+ default
+
+ # Disable building native code objects if we dont have/want ocamlopt
+ if ! use ocamlopt; then
+ sed -i -e 's/\.opt//' src/Makefile || die "failed to change native code compiler to bytecode ones"
+ sed -i -e 's/ facile\.cmxa//' src/Makefile || die "failed to remove native code objects"
+ sed -i -e 's/\.opt/.out/g' \
+ -e 's: src/facile\.cmxa::'\
+ -e 's: src/facile\.a::'\
+ -e 's:^.*facile\.cmxa::'\
+ -e 's:^.*facile\.a::' Makefile || die "failed to remove native code objects"
+ fi
+}
+
+src_configure(){
+ # This is a custom configure script and it does not support standard options
+ ./configure --faciledir "${D}"$(ocamlc -where)/facile/ || die
+}
+
+src_test() {
+ emake check
+}
+
+src_install(){
+ dodir $(ocamlc -where)
+ emake install
+ einstalldocs
+}
diff --git a/dev-ml/facile/files/facile-1.1-make.patch b/dev-ml/facile/files/facile-1.1-make.patch
new file mode 100644
index 000000000000..7b77639d2277
--- /dev/null
+++ b/dev-ml/facile/files/facile-1.1-make.patch
@@ -0,0 +1,48 @@
+diff -ur a/Makefile b/Makefile
+--- a/Makefile 2004-09-08 10:51:02 +0100
++++ b/Makefile 2007-10-23 13:11:28 +0100
+@@ -3,7 +3,7 @@
+ include config_Makefile
+
+ compile:
+- cd src; make
++ cd src; $(MAKE)
+
+ install:
+ if test -d $(FACILEDIR); then : ; else mkdir $(FACILEDIR); fi
+@@ -14,10 +14,10 @@
+ chmod a+r $(FACILEDIR)/facile.a
+
+ clean:
+- cd src; make clean
++ cd src; $(MAKE) clean
+
+ distclean uninstall:
+ rm -fr $(FACILEDIR)
+
+ check:
+- cd examples; make FACILEDIR=../src queens.opt; ./queens.opt 8
++ cd examples; $(MAKE) FACILEDIR=../src queens.opt; ./queens.opt 8
+diff -ur a/src/Makefile b/src/Makefile
+--- a/src/Makefile 2004-09-08 10:51:02 +0100
++++ b/src/Makefile 2007-10-23 13:10:34 +0100
+@@ -28,7 +28,7 @@
+ # Version of the library to be linked with the -p (profiler) option
+ facile.p.cmxa : $(CSTR)
+ rm -fr $(CSTRCMX)
+- make facile.cmxa OPTOPT=-p
++ $(MAKE) facile.cmxa OPTOPT=-p
+ rm -fr $(CSTRCMX)
+ mv facile.cmxa $@
+ mv facile.a facile.p.a
+@@ -41,8 +41,8 @@
+ # Does not work with many modules (e.g. containing class expressions
+ facile.exp.cmxa : $(CSTR)
+ rm -fr $(CSTRCMX)
+- make fcl_stak.cmx fcl_cstr.cmx fcl_inv.cmx fcl_reify.cmx fcl_arith.cmx fcl_goals.cmx fcl_fdArray.cmx fcl_gcc.cmx fcl_alldiff.cmx fcl_sorting.cmx fcl_interval.cmx facile.cmx
+- make facile.cmxa OPTOPT="-pp inline_functors"
++ $(MAKE) fcl_stak.cmx fcl_cstr.cmx fcl_inv.cmx fcl_reify.cmx fcl_arith.cmx fcl_goals.cmx fcl_fdArray.cmx fcl_gcc.cmx fcl_alldiff.cmx fcl_sorting.cmx fcl_interval.cmx facile.cmx
++ $(MAKE) facile.cmxa OPTOPT="-pp inline_functors"
+ rm -fr $(CSTRCMX)
+ mv facile.cmxa $@
+ mv facile.a facile.exp.a
diff --git a/dev-ml/facile/metadata.xml b/dev-ml/facile/metadata.xml
new file mode 100644
index 000000000000..41bad2f652fd
--- /dev/null
+++ b/dev-ml/facile/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+</pkgmetadata>