summaryrefslogtreecommitdiff
path: root/dev-ml/expect_test_helpers_core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-02 11:30:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-02 11:30:05 +0100
commit8164a4e49d69b936f2d820456e48468dc0e241ad (patch)
tree72c381896b721d4947b8f65f0cadceef779b99ae /dev-ml/expect_test_helpers_core
parentc3ec60d8953748433a04137e04480e9c1a36ed4c (diff)
gentoo auto-resync : 02:07:2023 - 11:30:05
Diffstat (limited to 'dev-ml/expect_test_helpers_core')
-rw-r--r--dev-ml/expect_test_helpers_core/Manifest2
-rw-r--r--dev-ml/expect_test_helpers_core/expect_test_helpers_core-0.16.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/expect_test_helpers_core/Manifest b/dev-ml/expect_test_helpers_core/Manifest
index 52265e8affa9..88f5985d6908 100644
--- a/dev-ml/expect_test_helpers_core/Manifest
+++ b/dev-ml/expect_test_helpers_core/Manifest
@@ -1,3 +1,5 @@
DIST expect_test_helpers_core-0.15.0.tar.gz 19807 BLAKE2B aca6103a7a50d7cf666ff6acb7b5430a5b0667efe039d200bc9ed2e430b91c4ed9a75378ceb0142e5d8d419ca6b3be508dc75c8e7fb5ff23101ebc012c70a9c0 SHA512 c08bda03c3bbc5c7ee1e970b5ba03e319826b7dd550d073f69b373bfa429c489ae1fcd388a2629f3d81729a96aac5614b4b1bcadd4040a290ffaab55b26bb9d6
+DIST expect_test_helpers_core-0.16.0.tar.gz 22549 BLAKE2B 2925c572a97a4bada839f98bea50f503d138d43550e1849ae23f4f553c5402c86135ad6ef1e57e9a5a382a2aae719bf88b8550399824294970350fbe0fa5d474 SHA512 057504994125e05c02264eef4766e58619d1f89039836b994487cc8627786c0e0d1491ab8a3ffa02ac19cb8d0754f4af88188a47d25cbe89c5a51b04ac002c95
EBUILD expect_test_helpers_core-0.15.0-r1.ebuild 605 BLAKE2B 5cdffe557d1eab94612208f354c6f81febc9c4316ceea9c25a49b6ccef874063fef66b350099756100a4f0478b34609c6f470f5393a0e59af8ca995e540954db SHA512 713f60d1243db0f567052c5a0274ec22185ffc7327c7307057c94a6b91338ae9d486c71f188d33929eedcea1ba62fca285f97ee4ebb92d27f3d17327e160fd08
+EBUILD expect_test_helpers_core-0.16.0.ebuild 632 BLAKE2B e92508403406c5053635cee287bc85742ddaf743e23a12e0db945fe70d2ef181b8c2b6d0ab63678a9839a6df4cfff98719e9e981c2bb1d3de5dcf8abb6a68dea SHA512 f6186c1068d7f74df133121a25ff1004cb2cdf691795f4d9e98cb0e45a89490b3ba6bf725c3cdb902921d0014b8f65a33ba6186016de145212607fc817d86dd4
MISC metadata.xml 333 BLAKE2B 050b0539a697bcb91bf635dd9a2fb6ee2daadd6e69a43ba4c0a70f84e5e76e083c6acb93a3628cd04415beebd5f78701e66932ad71111c39b3411a76c563cc65 SHA512 fdfb97d9c46e137d73de63c5ae1a998964ee51e9803352b88228b075c3d72b40d7baad760dc66efaf908cfca12a62ea2c697a6c52f0e1e6500715bc3244f5cb9
diff --git a/dev-ml/expect_test_helpers_core/expect_test_helpers_core-0.16.0.ebuild b/dev-ml/expect_test_helpers_core/expect_test_helpers_core-0.16.0.ebuild
new file mode 100644
index 000000000000..d9880e2ad159
--- /dev/null
+++ b/dev-ml/expect_test_helpers_core/expect_test_helpers_core-0.16.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Helpers for writing expectation tests"
+HOMEPAGE="https://github.com/janestreet/expect_test_helpers_core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:${SLOT}
+ dev-ml/core:${SLOT}
+ dev-ml/ppx_jane:${SLOT}
+ dev-ml/stdio:${SLOT}
+ dev-ml/sexp_pretty:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""