summaryrefslogtreecommitdiff
path: root/dev-ml/eliom/eliom-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ml/eliom/eliom-9999.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/eliom/eliom-9999.ebuild')
-rw-r--r--dev-ml/eliom/eliom-9999.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-ml/eliom/eliom-9999.ebuild b/dev-ml/eliom/eliom-9999.ebuild
deleted file mode 100644
index cffa1b2c77a6..000000000000
--- a/dev-ml/eliom/eliom-9999.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib findlib
-
-DESCRIPTION="A web framework to program client/server applications"
-HOMEPAGE="http://ocsigen.org/eliom/"
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/ocsigen/eliom"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/ocsigen/eliom/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0/${PV}"
-IUSE="doc +ocamlopt +ppx"
-
-RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]
- >=dev-ml/js_of_ocaml-2.8.2:=[xml]
- >=www-servers/ocsigenserver-2.8:=
- >=dev-ml/tyxml-4:=
- >=dev-ml/deriving-0.6:=
- >=dev-ml/reactiveData-0.2.1:=
- dev-ml/ocaml-ipaddr:=
- dev-ml/react:=
- dev-ml/ocaml-ssl:=
- >=dev-ml/lwt-2.5.0:=
- dev-ml/lwt_react:=
- dev-ml/camlp4:=
- ppx? ( >=dev-ml/ppx_tools-0.99.3:= )"
-DEPEND="${RDEPEND}
- dev-ml/ocamlbuild
- dev-ml/opam"
-
-src_compile() {
- if use ocamlopt ; then
- emake PPX=$(usex ppx true false) all
- else
- emake PPX=$(usex ppx true false) byte
- fi
- use doc && emake doc
- emake man
-}
-
-src_install() {
- opam-installer \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- --mandir="${ED}/usr/share/man" \
- || die
- dodoc CHANGES README.md
- if use doc ; then
- docinto client/html
- dodoc -r _build/src/lib/client/api.docdir/*
- docinto server/html
- dodoc -r _build/src/lib/server/api.docdir/*
- fi
-}