summaryrefslogtreecommitdiff
path: root/dev-ml/easy-format
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/easy-format
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/easy-format')
-rw-r--r--dev-ml/easy-format/Manifest5
-rw-r--r--dev-ml/easy-format/easy-format-1.0.2.ebuild33
-rw-r--r--dev-ml/easy-format/easy-format-1.2.0.ebuild33
-rw-r--r--dev-ml/easy-format/metadata.xml11
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-ml/easy-format/Manifest b/dev-ml/easy-format/Manifest
new file mode 100644
index 000000000000..910b2fede1cc
--- /dev/null
+++ b/dev-ml/easy-format/Manifest
@@ -0,0 +1,5 @@
+DIST easy-format-1.0.2.tar.gz 13679 BLAKE2B 5f738e521ef8eb59edbcba92f599328ab6f5e497075d8144335191835906832ecb4e4a8c6233c65f6f7aa7c4105aadd1dc1e269ad59a2c3237c54af8b3856e41 SHA512 bb12c13b33a725f4a15616672f7a268398b50e6f054575203f1d26c49aa04978564233fa9fb88eec8b701d7fecbbaeda264422e8c31a60a52d0d8e64bfc5898f
+DIST easy-format-1.2.0.tar.gz 15632 BLAKE2B 0bf20b87050330e90f3ef5cbe47470049ddc470d22357240f6b0ddd75138d3297935306c071e4355f02ed2fdd01a3155461e90a91df1346fa33180833db77b57 SHA512 375849b1ecd2e37f4b32d1ee12197a95856b17a47e3eb06a7e7320a82234c241156c3c8bfb18ce17bbe73b93d31d755675478860505470aa7ab866277a99603f
+EBUILD easy-format-1.0.2.ebuild 634 BLAKE2B d97bb030ba1a078ad8b8398de74cb20a20c566eeef1c38435487df3dfb4a64bae60db26877215d989d8192c6bc8ce14cd375e13f714aa54f54f9028e33188609 SHA512 7b317147f087ed422fd6c138ed281da1317eaf8d00be1b2e17208e451907736629f43ca72c7908112f24611878dadacc934138420355dc4d62568f7a24507e66
+EBUILD easy-format-1.2.0.ebuild 667 BLAKE2B 29a46d20176330c80d0d9bf7132bec4eec2ce7c0bf54f0eb41759336aa0737b00b7fd0ea737154f20058eb5dfb443aedfd15c38e5b1b198bbf3ce51870625f80 SHA512 f21275174e49404dcccef768d41925edf46040147a246760e12fe851444d1ec75117d83d62b499100306a96eb0ddffe37c6d3f6f9f9c8cd171790bd388540559
+MISC metadata.xml 331 BLAKE2B 7974c4e4a7994295e1b017181f909eab3dedf0ba105ef320e955873823e7ef068348157e33b5043fe82bb312eb7b2bcc1ffa60af547336544e13e272543c3f20 SHA512 9fd5bc86471c482e9a27378c05c582e49cf0a139b5d84d0ec4eafa3f85e12f02a12dee50a68649599a0239fcc54119cd89dbbe73b656722c1db712bcfd46684e
diff --git a/dev-ml/easy-format/easy-format-1.0.2.ebuild b/dev-ml/easy-format/easy-format-1.0.2.ebuild
new file mode 100644
index 000000000000..db163f33fd49
--- /dev/null
+++ b/dev-ml/easy-format/easy-format-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/easy-format.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples +ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/easy-format/easy-format-1.2.0.ebuild b/dev-ml/easy-format/easy-format-1.2.0.ebuild
new file mode 100644
index 000000000000..669c69092068
--- /dev/null
+++ b/dev-ml/easy-format/easy-format-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/mjambon/easy-format"
+SRC_URI="https://github.com/mjambon/easy-format/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples +ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/easy-format/metadata.xml b/dev-ml/easy-format/metadata.xml
new file mode 100644
index 000000000000..baf19ddebea0
--- /dev/null
+++ b/dev-ml/easy-format/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mjambon/easy-format</remote-id>
+ </upstream>
+</pkgmetadata>