summaryrefslogtreecommitdiff
path: root/dev-ml/dune/dune-2.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-ml/dune/dune-2.9.1.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-ml/dune/dune-2.9.1.ebuild')
-rw-r--r--dev-ml/dune/dune-2.9.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/dune/dune-2.9.1.ebuild b/dev-ml/dune/dune-2.9.1.ebuild
new file mode 100644
index 000000000000..93856341506f
--- /dev/null
+++ b/dev-ml/dune/dune-2.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="A composable build system for OCaml"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08:=
+ !dev-ml/jbuilder
+"
+DEPEND="
+ ${RDEPEND}
+ dev-ml/findlib
+ test? (
+ dev-ml/core_bench
+ dev-ml/ppx_bench
+ dev-ml/ppx_expect
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/dune"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ ocaml bootstrap.ml || die
+ ./dune.exe build -p "${PN}" --profile dune-bootstrap -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/doc "${ED}"/usr/share/doc/${PF} || die
+ mv "${ED}"/usr/man "${ED}"/usr/share/man || die
+}