summaryrefslogtreecommitdiff
path: root/dev-ml/dose3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/dose3
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/dose3')
-rw-r--r--dev-ml/dose3/Manifest5
-rw-r--r--dev-ml/dose3/dose3-5.0.1-r1.ebuild65
-rw-r--r--dev-ml/dose3/files/ocaml406.patch39
-rw-r--r--dev-ml/dose3/files/unix.patch13
-rw-r--r--dev-ml/dose3/metadata.xml5
5 files changed, 125 insertions, 2 deletions
diff --git a/dev-ml/dose3/Manifest b/dev-ml/dose3/Manifest
index f4d496dc8f8f..08e7827b7b85 100644
--- a/dev-ml/dose3/Manifest
+++ b/dev-ml/dose3/Manifest
@@ -1,3 +1,6 @@
+AUX ocaml406.patch 1623 BLAKE2B 741d94b936ed59aa3b158cca587ee2aaddb72e06703cbeee13c7aadb1c062d38bdb7a8e06805a7dc4cc6a19cab829702e55797f7434b3aea402c8d8023e36783 SHA512 1ccc378bb32a7ced3b643590a5ebd3b4b5b31f256ba4067f64a1611abb74cba48f0e0da42fb498aa66ee17e3d2446b9683ff5eca64749360af7a147fbf36385b
+AUX unix.patch 406 BLAKE2B 270b1e747ab9f270c49ea2ccfee0734600160f1db2f6ee912467989e1c59b31a0840d3a83fa857000b50a5a61d29422629bc9eb2334c7b08db93ef43d12229f7 SHA512 f6d7a3d100c425767ce304c620376cf815b8de59b04aea7ee439e79159cb7aa96cf1903498173d341fcf8d61391edf0b183ab4cda17ce91f41db9aa25ae8aff5
DIST dose3-5.0.1.tar.gz 297433 BLAKE2B 74ae954604f26398f091b4f14d2a633132ae62102f52af13284af27e41cd7c47afb1b533b0821a8921ba33fa6658e94b3bb6bf5f104f48881a50e14517cd65e2 SHA512 e66526319446054041f138ee2633043d0832089f6a554cf566a28de899d10383acfb1aa6bf1a368811602939676510933a7d2404fd34dbeba15045b458f5af84
+EBUILD dose3-5.0.1-r1.ebuild 1678 BLAKE2B 4d9ee4f7be0f91bdbbd92d256202e0a7f4f93ada147e95d4b8df002d0583636d87a81e9d59b060b13b51560786099c42451f6c5a1f31f2766c994878fcd39308 SHA512 ab0fceac967da108330269bb6b8a845e9a6406ffd3aaf83fb2ca16fa5d1bdedf31c05ab1986823e2c9b39ed1ec83409b1c2e369ad556dadb03e85d518e059ba2
EBUILD dose3-5.0.1.ebuild 1541 BLAKE2B d1bb17c74e7f0882ff94993c4aa1cefaed79445cc413d827e4ba9283df807798f9f11510dcd8078beb7b382c0c18127b269e80ea187e72c12b5c9cc32e885e44 SHA512 01cf87d3a0e2f817801ecdfadefb8e34f18b2676b34488559c324020edf76ceccd5268941f20edaccfd75a4275c1a724f2a7f7d9352a165c438fa0b977878ab5
-MISC metadata.xml 397 BLAKE2B a1b2f753f172edfb0ac6883028f382b3c43a60df7850bd587a178e0f80a9f825fe7ca701670f30f2746816a02abf6f32a66e425257dba614006648a360a5ead7 SHA512 faf958e0196a8f044a39071b0d55b8d87417d4b5edc5086828c1d1cd86c38c272b844d2e5e4d9bb36dcda8c24b362b70f5707496ff490f02296ab0f2d4532524
+MISC metadata.xml 474 BLAKE2B 51884c8074342dbbe0e961495b12b69460ba0429134c50a75c68008fe54a8ea89dce28e114553b433f7c8dca503daee89b858c92995fd0aa4651bd1335e87a62 SHA512 245deea20a81b03063b19e4146982bd6a6d64b363153cdcdde811800c64f8d72861f749eac232f6530889ceb2fa84828db83376039868d3a097b488ba6331ee2
diff --git a/dev-ml/dose3/dose3-5.0.1-r1.ebuild b/dev-ml/dose3/dose3-5.0.1-r1.ebuild
new file mode 100644
index 000000000000..c08cc798c4d6
--- /dev/null
+++ b/dev-ml/dose3/dose3-5.0.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${P/_beta/-beta}"
+DESCRIPTION="Library to perform analysis on package repositories"
+HOMEPAGE="http://www.mancoosi.org/software/ https://gforge.inria.fr/projects/dose"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/36063/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt parmap zip bzip2 xml curl rpm4 test"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/cudf:=
+ >=dev-ml/extlib-1.7.0:=
+ dev-ml/re:=
+ parmap? ( dev-ml/parmap:= )
+ zip? ( dev-ml/camlzip:= )
+ bzip2? ( dev-ml/camlbz2:= )
+ >=dev-ml/ocamlgraph-1.8.6:=
+ xml? ( dev-ml/ocaml-expat:= dev-ml/xml-light:= )
+ curl? ( dev-ml/ocurl:= )
+ rpm4? ( app-arch/rpm )
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/cppo
+ test? ( dev-python/pyyaml[libyaml] )
+"
+# missing test data
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -e 's/INSTALLOPTS=-s/INSTALLOPTS=/' -i Makefile.config.in || die
+ has_version '>=dev-lang/ocaml-4.06_beta' && eapply "${FILESDIR}/ocaml406.patch"
+ eapply "${FILESDIR}/unix.patch"
+}
+
+src_configure() {
+ econf \
+ $(use ocamlopt || echo "--with-bytecodeonly") \
+ $(use parmap && echo "--with-parmap") \
+ $(use zip && echo "--with-zip") \
+ $(use bzip2 && echo "--with-bz2") \
+ $(use xml && echo "--with-xml") \
+ $(use curl && echo "--with-curl") \
+ $(use rpm4 && echo "--with-rpm4")
+}
+
+src_compile() {
+ emake -j1 VERBOSE="-classic-display"
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR="${ED}/usr/bin" install || die
+ dodoc CHANGES CREDITS README.architecture TODO
+}
diff --git a/dev-ml/dose3/files/ocaml406.patch b/dev-ml/dose3/files/ocaml406.patch
new file mode 100644
index 000000000000..867c2ca4848c
--- /dev/null
+++ b/dev-ml/dose3/files/ocaml406.patch
@@ -0,0 +1,39 @@
+Index: dose3-5.0.1/common/criteria_lexer.mll
+===================================================================
+--- dose3-5.0.1.orig/common/criteria_lexer.mll
++++ dose3-5.0.1/common/criteria_lexer.mll
+@@ -18,7 +18,7 @@
+ let c = Lexing.lexeme_char lexbuf 2 in (* the delimiter can be any character *)
+ (* find the terminating delimiter *)
+ let endpos =
+- try String.index_from lexbuf.lex_buffer (lexbuf.lex_start_pos + 3) c with
++ try Bytes.index_from lexbuf.lex_buffer (lexbuf.lex_start_pos + 3) c with
+ |Invalid_argument _ ->
+ raise (Format822.Syntax_error (
+ Format822.error lexbuf "String too short"))
+@@ -27,9 +27,9 @@
+ Format822.error lexbuf (Printf.sprintf "cannot find: %c" c)))
+ in
+ let len = endpos - (lexbuf.lex_start_pos + 3) in
+- let s = String.sub lexbuf.lex_buffer (lexbuf.lex_start_pos + 3) len in
+- lexbuf.Lexing.lex_curr_pos <- lexbuf.Lexing.lex_start_pos + ((String.length s)+4);
+- s
++ let s = Bytes.sub lexbuf.lex_buffer (lexbuf.lex_start_pos + 3) len in
++ lexbuf.Lexing.lex_curr_pos <- lexbuf.Lexing.lex_start_pos + ((Bytes.length s)+4);
++ Bytes.to_string s
+
+ }
+
+Index: dose3-5.0.1/common/input.ml
+===================================================================
+--- dose3-5.0.1.orig/common/input.ml
++++ dose3-5.0.1/common/input.ml
+@@ -47,7 +47,7 @@ let bzip_open_file file =
+ in
+ IO.create_in
+ ~read:(fun () -> input_char ch)
+- ~input:(read ch)
++ ~input:(fun x -> read ch (Bytes.to_string x))
+ ~close:(fun () -> Bz2.close_in ch)
+ #else
+ fatal "bzip not supported. re-configure with --with-bz2"
diff --git a/dev-ml/dose3/files/unix.patch b/dev-ml/dose3/files/unix.patch
new file mode 100644
index 000000000000..c3dbfabcfbce
--- /dev/null
+++ b/dev-ml/dose3/files/unix.patch
@@ -0,0 +1,13 @@
+Index: dose3-5.0.1/META.in
+===================================================================
+--- dose3-5.0.1.orig/META.in
++++ dose3-5.0.1/META.in
+@@ -8,7 +8,7 @@ package "common" (
+ version = "@PACKAGE_VERSION@"
+ archive(byte) = "common.cma"
+ archive(native) = "common.cmxa"
+-requires = "extlib, re.pcre, cudf, @ZIP@, @BZ2@"
++requires = "extlib, re.pcre, cudf, unix, @ZIP@, @BZ2@"
+ )
+
+ package "algo" (
diff --git a/dev-ml/dose3/metadata.xml b/dev-ml/dose3/metadata.xml
index 35cab394ef66..99daf30cfd99 100644
--- a/dev-ml/dose3/metadata.xml
+++ b/dev-ml/dose3/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
<use>
<flag name="parmap">Adds multi-core CPU support via <pkg>dev-ml/parmap</pkg>.</flag>
<flag name="zip">Adds support for handling zip files.</flag>