summaryrefslogtreecommitdiff
path: root/dev-ml/dns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/dns
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/dns')
-rw-r--r--dev-ml/dns/Manifest3
-rw-r--r--dev-ml/dns/dns-1.0.0.ebuild43
-rw-r--r--dev-ml/dns/metadata.xml11
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-ml/dns/Manifest b/dev-ml/dns/Manifest
new file mode 100644
index 000000000000..fa9512b75b58
--- /dev/null
+++ b/dev-ml/dns/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-dns-1.0.0.tar.gz 99161 SHA256 823410badaf2faf54ca8a59472b0ad82c4db9fe4ef92f6809061baa826851226 SHA512 199653605e985851dcaafc94f1efeba5c261c29cd5e5f8eaebc9f7d25a05c43adcf7620efb291b22f9549f7c05f8ac3f6abfbcf40e0d7762bd2f7cd623ebcb1c WHIRLPOOL e7c26857270d92be2e8e068ac29119ef5d82d52fd739b8304e84c595d6a6e7fc11c22ed98e4a6d99a20f4e9d1d6b28dbc76c333d6b464bbd1dc4d37597cfe66c
+EBUILD dns-1.0.0.ebuild 864 SHA256 f07c324f65a440ae9a64ee241d415367a6e2dfb400ce51434e725f4c6aa089dd SHA512 c8d8a430e397dd6db98c9f1cf0cec5ab43d7789451f687e37a337449b8ca6b34030f1631a0fe2464ad1920397d73de2db242f927d78aa7845e4f2dbf10aba356 WHIRLPOOL a5accf679bed679d10b14bfa7d10de62baf9e3faed812e73e0a7389986bf476181dfdb48975262d541aab0ef106265a8c702a66a97915600c6ea82f79dc6e919
+MISC metadata.xml 357 SHA256 ab112ea05e172fd6ae8ed46e6d2cc5e7d235fc6cf38d55c0a69b02243c7bcc76 SHA512 9e3065fb6377e861b64a34f9fafd75e33a0edb081d273a8918b494a1d6f79c63ffb2c9b33bd854bb893fa020652c15b575d3e16e08266895239c082f28429633 WHIRLPOOL a2d9399b37c27bab7a3b137a828ba9e0038228c1f9f3a4fb0e04c6d3e737acc591a98bad801b9fe2d6449caf70fe5952397badda1c98c25731f3f81fa8420c58
diff --git a/dev-ml/dns/dns-1.0.0.ebuild b/dev-ml/dns/dns-1.0.0.ebuild
new file mode 100644
index 000000000000..1780cf1361f4
--- /dev/null
+++ b/dev-ml/dns/dns-1.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+DESCRIPTION="A pure OCaml implementation of the DNS protocol"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ocaml-${P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-ml/ocaml-base64-2.0.0:=
+ >=dev-ml/ocaml-cstruct-3.0.2:=[ppx]
+ dev-ml/ocaml-hashcons:=
+ >=dev-ml/ocaml-ipaddr-2.6.0:=
+ dev-ml/ocaml-re:=
+ >=dev-ml/ocaml-uri-1.7.0:=
+ dev-ml/result:=
+ !dev-ml/odns
+"
+DEPEND="
+ dev-ml/jbuilder
+ ${RDEPEND}
+"
+
+# Do not work
+RESTRICT="test"
+
+S="${WORKDIR}/ocaml-${P}"
+
+src_compile() {
+ jbuilder build @install -p dns || die
+}
+
+src_test() {
+ jbuilder runtest -p dns || die
+}
diff --git a/dev-ml/dns/metadata.xml b/dev-ml/dns/metadata.xml
new file mode 100644
index 000000000000..2f4ef14adaa5
--- /dev/null
+++ b/dev-ml/dns/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-dns</remote-id>
+ </upstream>
+</pkgmetadata>