summaryrefslogtreecommitdiff
path: root/dev-ml/cstruct/cstruct-5.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /dev-ml/cstruct/cstruct-5.2.0.ebuild
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'dev-ml/cstruct/cstruct-5.2.0.ebuild')
-rw-r--r--dev-ml/cstruct/cstruct-5.2.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/cstruct/cstruct-5.2.0.ebuild b/dev-ml/cstruct/cstruct-5.2.0.ebuild
new file mode 100644
index 000000000000..f2b874f5dceb
--- /dev/null
+++ b/dev-ml/cstruct/cstruct-5.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MYP=${PN}-v${PV}
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/ocaml-${PN}/releases/download/v${PV}/${MYP}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-ml/async_unix:=
+ dev-ml/bigarray-compat:=
+ >=dev-ml/ppx_tools_versioned-5.4.0:="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MYP}