summaryrefslogtreecommitdiff
path: root/dev-ml/cppo/cppo-1.6.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-26 03:55:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-26 03:55:42 +0000
commit61044571b76d87a2eec42d36c9b7addf3e66e000 (patch)
tree5ac1c90c51a6331aabe26008ffb1150a72d7d2d0 /dev-ml/cppo/cppo-1.6.8-r1.ebuild
parentef596bcaa32d9c69d88a3451193cb242da803db1 (diff)
gentoo auto-resync : 26:02:2023 - 03:55:42
Diffstat (limited to 'dev-ml/cppo/cppo-1.6.8-r1.ebuild')
-rw-r--r--dev-ml/cppo/cppo-1.6.8-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ml/cppo/cppo-1.6.8-r1.ebuild b/dev-ml/cppo/cppo-1.6.8-r1.ebuild
new file mode 100644
index 000000000000..66030d3bfc18
--- /dev/null
+++ b/dev-ml/cppo/cppo-1.6.8-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="https://github.com/ocaml-community/cppo/"
+SRC_URI="https://github.com/ocaml-community/cppo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-ml/ocamlbuild:=
+ dev-ml/findlib:="
+DEPEND="${RDEPEND}"