summaryrefslogtreecommitdiff
path: root/dev-ml/core_unix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
commite53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (patch)
treedd095d36490410a724fd271fcdf08c31a5336edd /dev-ml/core_unix
parentc5ee568457ac776b65b71fa444e0dd47535bc44a (diff)
gentoo auto-resync : 28:01:2023 - 02:49:59
Diffstat (limited to 'dev-ml/core_unix')
-rw-r--r--dev-ml/core_unix/Manifest2
-rw-r--r--dev-ml/core_unix/core_unix-0.15.2.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/core_unix/Manifest b/dev-ml/core_unix/Manifest
index 2df655a6c593..a8381206d8f1 100644
--- a/dev-ml/core_unix/Manifest
+++ b/dev-ml/core_unix/Manifest
@@ -1,3 +1,5 @@
DIST core_unix-0.15.0.tar.gz 377928 BLAKE2B 49b58471a28c356bdf39f15e22bd21ec4363182cf744c0455847ffc15015fdad2928a428986c2a9edff647ebef9f2ad2059b184b393e979119c8f007f67ec140 SHA512 eeb53bd0c06a7d1facfb133f0a45a232d57941eff644d4ed6c2d5002acd4e6b323376ec9c05838f760ebd9da3fbc39332989ed50b3921191c175811c947fcbfe
+DIST core_unix-0.15.2.tar.gz 377836 BLAKE2B 56551ab1509bfecc59ae4b45aaaa4d336415cffe9339932239c884bc86207bdb4066aace35144618509b78b461164bdfaaaa04030ecb1b3619de6f8fe5c3a7b9 SHA512 6d59c52111235f952f3052fb86af1d7380ff3d8d89b5c8d59a66d530a14d462fa4b06cdf29f2ee2b4356a574dbefef33b82f60f9fba512942bc0e6aad07f2b6f
EBUILD core_unix-0.15.0.ebuild 577 BLAKE2B 1fd5f1ae602502ef50267d88f5788a66388153082066863e191115b58154059d577e079dca5818982133812070909249a548ca205912ba38c184278c8a5498dc SHA512 318fb4a1c646219119c85d42205986de3745b3755031db4d2baf3f3f8bf59cfe57991a167fd14fe88e8b62b5d91f02e62ba47ecd2aaf4d0ea81439ea855f1f9f
+EBUILD core_unix-0.15.2.ebuild 600 BLAKE2B 55b23cb5949996e744ce17e4a88dc4e6b6197c8b06d2d071a2cf5b232b489f106cec1a7d989294c4731ef02854e87e93292bb3ebdaa3e55f3572257cd858ff97 SHA512 7bbed83a12d94fcb974effaac7531a929b43bdda1099064322c3dc8374fce9359a4ba82b1d18259fb9bbd8677fc7b7eed061ad0825c451aae522ca84ec4d67f1
MISC metadata.xml 318 BLAKE2B 2179bfab915d936189f80d0c10ee6367fe5ad711df66647da644fa05d8b1b9778d83d2862228955fc11621368a523fa904b639c47a4d8843b42e561127f94baf SHA512 66ae67f04d4f63ed5940c7164f0bfb27097e066c30d07a01c3d773b8b40a7ff6c8f0632e1103b952d310120cc0111690b93495fd0ac6c582652c627006e24bae
diff --git a/dev-ml/core_unix/core_unix-0.15.2.ebuild b/dev-ml/core_unix/core_unix-0.15.2.ebuild
new file mode 100644
index 000000000000..2114a6c14a77
--- /dev/null
+++ b/dev-ml/core_unix/core_unix-0.15.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit dune
+
+DESCRIPTION="Unix-specific portions of Core"
+HOMEPAGE="https://github.com/janestreet/core_unix"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.09
+ dev-ml/core_kernel:${SLOT}
+ dev-ml/expect_test_helpers_core:${SLOT}
+ dev-ml/ocaml_intrinsics:${SLOT}
+ dev-ml/timezone:${SLOT}
+ dev-ml/spawn:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""