summaryrefslogtreecommitdiff
path: root/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-21 00:01:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-21 00:01:06 +0100
commitd33b3cf6cff9fdbfc8362bf854c3c34b2c28d518 (patch)
tree7fb87b3c81930bc74ab84958c42e07fde61f6b7f /dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
parent1e2d947ea35b8fd5d14d55f60265f9763fa70a72 (diff)
gentoo auto-resync : 21:04:2023 - 00:01:05
Diffstat (limited to 'dev-ml/core_unix/core_unix-0.15.2-r1.ebuild')
-rw-r--r--dev-ml/core_unix/core_unix-0.15.2-r1.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild b/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
index c543a96d0275..ae132f20399d 100644
--- a/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
+++ b/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit dune
+inherit dune toolchain-funcs
DESCRIPTION="Unix-specific portions of Core"
HOMEPAGE="https://github.com/janestreet/core_unix"
@@ -25,3 +25,14 @@ DEPEND="
"
RDEPEND="${DEPEND}"
BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-musl.patch )
+
+src_prepare() {
+ sed -i \
+ -e "s:gcc:$(tc-getCC):" \
+ unix_pseudo_terminal/src/discover.sh \
+ || die
+
+ default
+}