summaryrefslogtreecommitdiff
path: root/dev-ml/core/core-0.9.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/core/core-0.9.1-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/core/core-0.9.1-r1.ebuild')
-rw-r--r--dev-ml/core/core-0.9.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/core/core-0.9.1-r1.ebuild b/dev-ml/core/core-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..45cc74eb4553
--- /dev/null
+++ b/dev-ml/core/core-0.9.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/base:=
+ dev-ml/configurator:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/sexplib:=
+ dev-ml/spawn:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/jbuilder"
+PATCHES=( "${FILESDIR}/glibc225.patch" )