summaryrefslogtreecommitdiff
path: root/dev-ml/cinaps/cinaps-0.15.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /dev-ml/cinaps/cinaps-0.15.1.ebuild
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'dev-ml/cinaps/cinaps-0.15.1.ebuild')
-rw-r--r--dev-ml/cinaps/cinaps-0.15.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/cinaps/cinaps-0.15.1.ebuild b/dev-ml/cinaps/cinaps-0.15.1.ebuild
new file mode 100644
index 000000000000..beef48458589
--- /dev/null
+++ b/dev-ml/cinaps/cinaps-0.15.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Trivial metaprogramming tool"
+HOMEPAGE="https://github.com/ocaml-ppx/cinaps"
+SRC_URI="https://github.com/ocaml-ppx/cinaps/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-ml/re:="
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? (
+ dev-ml/ppx_jane
+ )
+"