summaryrefslogtreecommitdiff
path: root/dev-ml/cinaps/cinaps-0.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/cinaps/cinaps-0.14.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/cinaps/cinaps-0.14.0.ebuild')
-rw-r--r--dev-ml/cinaps/cinaps-0.14.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/cinaps/cinaps-0.14.0.ebuild b/dev-ml/cinaps/cinaps-0.14.0.ebuild
new file mode 100644
index 000000000000..f343badc16a9
--- /dev/null
+++ b/dev-ml/cinaps/cinaps-0.14.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Trivial metaprogramming tool"
+HOMEPAGE="https://github.com/ocaml-ppx/cinaps"
+SRC_URI="https://github.com/ocaml-ppx/cinaps/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-ml/findlib:=
+ dev-ml/re:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+DEPEND="${DEPEND}
+ test? (
+ dev-ml/ppx_jane
+ )
+"