summaryrefslogtreecommitdiff
path: root/dev-ml/camlzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-ml/camlzip
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/Manifest2
-rw-r--r--dev-ml/camlzip/camlzip-1.11.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
index 7d23d2bd5160..78762dc13491 100644
--- a/dev-ml/camlzip/Manifest
+++ b/dev-ml/camlzip/Manifest
@@ -1,3 +1,5 @@
DIST camlzip-1.10.tar.gz 27335 BLAKE2B bbf24953634278589395dd9fcedf1e3becce8dad1f380393dc3ac59589143e1685dc14085ef566e12fb751c6f1a333dd368795a5083b94a43b71e058e86489f3 SHA512 5c42e0d808230e3820b2e7ef34b544ca51a7bf0a484ce4e1c8b1e4966133196bb3ff7c3ca85b9c50050aca389316eb52f0335f6e2ad60c000594a33171b9a9a9
+DIST camlzip-1.11.tar.gz 28483 BLAKE2B b270e2a764547117d87a18f9ccca82891bc0dce182ea84f76b693acb34488ff25d8975154b843787554798bfd34c16dc6a25c431f8674c8c59eb2c195167c12b SHA512 4d69ef900437e66e00cd345497ec70f407f28cd8344ee5f2fad685d3bfe356924597d1854b752f2841b4007f96d6e0307cfae7e13cfb6f74951ae3eba5198a06
EBUILD camlzip-1.10.ebuild 903 BLAKE2B 8c3f6b59e4efeed7418ddf85d711bb41fc3b30a0e02e6f169d5cd0d604b43412fb54ff9b16e79168c413b0cb168900d8e42e0a8dee0e3e86877e00a4572051d2 SHA512 9525f5b22a9ef4c20a518e3cc05ec820cc92c7cdf16b6a10e35ade61678d3d18e81408fadbbe1e6261f389e5e6b5c6c96dfa917e734033d68fde6741c57f9dca
+EBUILD camlzip-1.11.ebuild 910 BLAKE2B b5292983f3976f79961e77496af5c89499fa0ee28140d84dd8caf293e14844e02002507cf7e73b3ddee9210346e227313ce55d4dc887d94a1d4b282117ce7fe2 SHA512 6ecfb6c0cdc8d535bf9bc2979512e62b4c4a04b99adff6d3b4f7f22cc51dc140477fd6bab53fccd525d971e12c8e31ed17cadb99c064f5cb5e47af1572018806
MISC metadata.xml 317 BLAKE2B d2d9b49548ab2d8a585cb4823b37b990805229909bb3ab23596ac5d916d2e7a2fe56153b1793d5e0979159e97f28289e14ded93d943541b7ab8def4cc195874b SHA512 5b7aa5dfdc7ec25161029b2d96a2596458b5507359fe25ff82268a98038f8d66f4fc095715348990d7116877035e17b0a2ed2d5541a990dcab1bd0155cc12ba1
diff --git a/dev-ml/camlzip/camlzip-1.11.ebuild b/dev-ml/camlzip/camlzip-1.11.ebuild
new file mode 100644
index 000000000000..09d1e837bb67
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="https://github.com/xavierleroy/camlzip"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+LICENSE="LGPL-2.1"
+SLOT="1/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.07:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+QA_FLAGS_IGNORED=(
+ "usr/lib.*/ocaml/stublibs/dllcamlzip.so"
+ "usr/lib.*/ocaml/zip/zip.cmxs"
+)
+
+src_compile() {
+ emake all
+
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+
+ emake DESTDIR="${D}" install-findlib
+ dosym zip/libcamlzip.a /usr/$(get_libdir)/ocaml/libcamlzip.a
+
+ dodoc README.md Changes
+}