summaryrefslogtreecommitdiff
path: root/dev-ml/camlzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/camlzip
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/Manifest5
-rw-r--r--dev-ml/camlzip/camlzip-1.06.ebuild34
-rw-r--r--dev-ml/camlzip/camlzip-1.07.ebuild36
-rw-r--r--dev-ml/camlzip/metadata.xml11
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
new file mode 100644
index 000000000000..c9b62b1852dd
--- /dev/null
+++ b/dev-ml/camlzip/Manifest
@@ -0,0 +1,5 @@
+DIST camlzip-1.06.tar.gz 26499 BLAKE2B a7a1dbe157c0dcb9847bcd6324bbb7cbaf39342d0fdbaed51d2c004ae7b03f8d655fb15da50dae6190b976675e405e28fa2d4fa35a2f4372c50519564d58f981 SHA512 5ef0172927106589620678897f12f054533503a5cf13df71bf4deda43f223d0cd6acce118977e87bce53afe289f367b851f192a8e693274c2bd13549121019dd
+DIST camlzip-1.07.tar.gz 26652 BLAKE2B f373ac0427faa9b6a846e9db8f3e48c00ec6885b8a11cc09fae96b5a7656908f172fda73dbea8ddd1b3dbfd98bcfa3e2e67ce9faf2942d1e260fc0a804813a05 SHA512 b92e9db002b9b398fd132c6ecd8098fac4cc7ddb3f770cc412990dcdf4bd62ba358c762d31fb0b5cd6b32f20d3bf4b3410ca6e86c511a438b92ece940f9831bd
+EBUILD camlzip-1.06.ebuild 688 BLAKE2B c1464425312b8825f76843ff05e913bd4fb85223ea7312c2b0dc7c0b6178f58c6df1b31474a1f69af286fafe586d6d234950612f1bf48214edae968089c40a9d SHA512 cd8ec9aadf5e74096c48c49b7316518a9af3a41dae9abbe92c9441dc5b83ba7b335808827722a7f795e5e42d44eaadafe9bd579ee4d15c2803651957ab56bb1b
+EBUILD camlzip-1.07.ebuild 823 BLAKE2B a569ebdb617046069ec484fa353c7fbbf550443667f96f4962480fdfe41e6ca33cca0859e0bceaddfc215d80096f0ac0fb68627317079630d8c50abcbc19eedf SHA512 36f894cac34b563204dc06b1df10d98332366ecbd66821f2513ed057fdc54650abe664f777b073e04730963b8cfe1514fc1aba3a45bc4c9ebdc6aedca947c703
+MISC metadata.xml 331 BLAKE2B ed79189ab7c0f0410de2ee3d342f0cfed3b37aaa91be8a69ecea9742c00a12f4180f7babf3be9fd3ab4be4c5b83702cacb5302ee98f39ad23d78d67121fdbb1c SHA512 f282b3605f8d97e4789545f6a8fe443dd25fa1af5f8d11f56dea6ffc513eb8ce3d858fc3335ed501f2d26dd7d38da41f1e3e3e21f90dd111de81107c56276310
diff --git a/dev-ml/camlzip/camlzip-1.06.ebuild b/dev-ml/camlzip/camlzip-1.06.ebuild
new file mode 100644
index 000000000000..360a11fbf5b7
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.06.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="http://forge.ocamlcore.org/projects/camlzip/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1616/${P}.tar.gz"
+
+SLOT="1/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${D}" install-findlib
+
+ dodoc README Changes
+}
diff --git a/dev-ml/camlzip/camlzip-1.07.ebuild b/dev-ml/camlzip/camlzip-1.07.ebuild
new file mode 100644
index 000000000000..23881c07e55b
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.07.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib eutils versionator
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="https://github.com/xavierleroy/camlzip"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(delete_all_version_separators ${PV}).tar.gz -> ${P}.tar.gz"
+
+SLOT="1/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-rel$(delete_all_version_separators ${PV})"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${D}" install-findlib
+
+ dodoc README Changes
+}
diff --git a/dev-ml/camlzip/metadata.xml b/dev-ml/camlzip/metadata.xml
new file mode 100644
index 000000000000..a6ac295dcc2a
--- /dev/null
+++ b/dev-ml/camlzip/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xavierleroy/camlzip</remote-id>
+ </upstream>
+</pkgmetadata>