summaryrefslogtreecommitdiff
path: root/dev-ml/camlzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-17 04:04:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-17 04:04:27 +0100
commit8796aaedb3257bbe4d80b0033408b2210b2259d6 (patch)
tree1ffee2ca4a87bd5dba43077259c000f9086fbfc8 /dev-ml/camlzip
parent61a1cada8ceb208845fa604b982216b0a7b099cb (diff)
gentoo auto-resync : 17:10:2024 - 04:04:26edge
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/Manifest2
-rw-r--r--dev-ml/camlzip/camlzip-1.12.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
index f7a0b2266f49..941e5b9bb5ed 100644
--- a/dev-ml/camlzip/Manifest
+++ b/dev-ml/camlzip/Manifest
@@ -1,5 +1,7 @@
DIST camlzip-1.10.tar.gz 27335 BLAKE2B bbf24953634278589395dd9fcedf1e3becce8dad1f380393dc3ac59589143e1685dc14085ef566e12fb751c6f1a333dd368795a5083b94a43b71e058e86489f3 SHA512 5c42e0d808230e3820b2e7ef34b544ca51a7bf0a484ce4e1c8b1e4966133196bb3ff7c3ca85b9c50050aca389316eb52f0335f6e2ad60c000594a33171b9a9a9
DIST camlzip-1.11.tar.gz 28483 BLAKE2B b270e2a764547117d87a18f9ccca82891bc0dce182ea84f76b693acb34488ff25d8975154b843787554798bfd34c16dc6a25c431f8674c8c59eb2c195167c12b SHA512 4d69ef900437e66e00cd345497ec70f407f28cd8344ee5f2fad685d3bfe356924597d1854b752f2841b4007f96d6e0307cfae7e13cfb6f74951ae3eba5198a06
+DIST camlzip-1.12.tar.gz 30453 BLAKE2B 7706879ab3e9d128428404592cc506c681794233ab2efe4c99fe46fdb10b17197aca82f6dd018afdd898d05fa136d1aaebfc54c0255b3b086fc02338c5b67822 SHA512 467c82a253440caf3d8485c949c4717b77dfdeb38ee474278be8e011ed3cd563fdcf436bc262e2c88fd27b44306f70d48808f0d001b3f62ab4c87010af61f76f
EBUILD camlzip-1.10.ebuild 904 BLAKE2B 682ca8abdb41d8c1e2ab45089e1310fe34c600852003b59fe06fa88cc0c808ad8db048ff22fde40f4d52bc9ebeb4e9b38c65331f746f339bf9fd4848aeee045d SHA512 ff48de9f754549f4d595280b9d63b3f492abb0a2c67ae75ece55afba30fd4d25c6f648aa1e0e35a06b5db3bccc8b91f9f05def4acea07300328e44bebb405d8a
EBUILD camlzip-1.11.ebuild 915 BLAKE2B 813c0df5901747a676e1a922a10c195184789630af113f87b7dbedc2dc755b60217af30a0e9193ee4871556160a1d9a127a45722997834a248f6b276cd3363d8 SHA512 42de8896634d3cb956d60071f7154c0a29e6884bfbfaaab23b4e40cb2fb286c47b620883e324b397bbf4194fbae6851127401ca06f6057ebae9210f1c5da03eb
+EBUILD camlzip-1.12.ebuild 920 BLAKE2B 364f41b76241b1c587abe0aa3902ff828dd0f4523265ab6d3098cf595ac26421c15c13785a0e996669ce793bebbae34f2626934f70730beaef4a04e4630fce1c SHA512 34663220d9f36b94863a512467815e02606975e07b4ccb36515f25da8ca20cba0133cdea2feac48880440a192d778c2999b4ccfed0696a8618cba3e1636c392a
MISC metadata.xml 317 BLAKE2B d2d9b49548ab2d8a585cb4823b37b990805229909bb3ab23596ac5d916d2e7a2fe56153b1793d5e0979159e97f28289e14ded93d943541b7ab8def4cc195874b SHA512 5b7aa5dfdc7ec25161029b2d96a2596458b5507359fe25ff82268a98038f8d66f4fc095715348990d7116877035e17b0a2ed2d5541a990dcab1bd0155cc12ba1
diff --git a/dev-ml/camlzip/camlzip-1.12.ebuild b/dev-ml/camlzip/camlzip-1.12.ebuild
new file mode 100644
index 000000000000..e68f0345ce9f
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="https://github.com/xavierleroy/camlzip"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+LICENSE="LGPL-2.1"
+SLOT="1/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.13:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+QA_FLAGS_IGNORED=(
+ "usr/lib.*/ocaml/stublibs/dllcamlzip.so"
+ "usr/lib.*/ocaml/zip/zip.cmxs"
+)
+
+src_compile() {
+ emake allbyt
+
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+
+ emake DESTDIR="${D}" install-findlib
+ dosym zip/libcamlzip.a /usr/$(get_libdir)/ocaml/libcamlzip.a
+
+ dodoc README.md Changes
+}