summaryrefslogtreecommitdiff
path: root/dev-ml/camlpdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/camlpdf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/camlpdf')
-rw-r--r--dev-ml/camlpdf/Manifest4
-rw-r--r--dev-ml/camlpdf/camlpdf-2.1.1.ebuild40
-rw-r--r--dev-ml/camlpdf/files/ocaml43.patch13
-rw-r--r--dev-ml/camlpdf/metadata.xml11
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-ml/camlpdf/Manifest b/dev-ml/camlpdf/Manifest
new file mode 100644
index 000000000000..169de865a649
--- /dev/null
+++ b/dev-ml/camlpdf/Manifest
@@ -0,0 +1,4 @@
+AUX ocaml43.patch 513 BLAKE2B 0e072dd9550e836739405bce85d81c38e5f03c4c8c6b400113c1b18a7719f65d82bb2e965337abbd41f9c4407dbad89ed9f289af9cb2b2d9eb8f501f8c346e97 SHA512 d0208633e71699fda0335b4542ef1d888ea8d090debe248dbbcaa0ce056df3f89cc7dc3d58d9fd8c3f329dc1b13b0481a1b0f5e0c832490d7efe314c4e5e3442
+DIST camlpdf-2.1.1.tar.gz 563633 BLAKE2B 3ff7ec46bbac70eabe6695911e834a5f2122136fecba661ff708c86dfb8d928694d67054504028670c3138c600f7f770b540d87c4e1a0ed1e04c71e083afdc23 SHA512 db6f9f61c43113e1f4d8741d88766bacc489a45b8e7164e4619f8bb88c527bc7cbeebdaaa673a77ab16c60dc3c90d21a69844e9fed92c222fc8fe0424f328cf2
+EBUILD camlpdf-2.1.1.ebuild 894 BLAKE2B 634572c7d71247b979133d041e3cb02bebe7be7f08e3afb0c054ac793b46b8887754b4d7ed28d216075bdeb015eb5c0a7dc07db8b2e3d46df90b207e0a420445 SHA512 5fb9224253ff7e7e00ca265be4cbea3894b9dc6604104f95b6a581449ea099f60c1796d248648fca59cb2bae1ce0fa9728a84834df1bc58e21860eb79a8045f1
+MISC metadata.xml 343 BLAKE2B 66027af918b340e99bb310ca9a0aa08b629ce77e509238a0bebba37825aab79787ca274f61b920e0aa23028d1cf4589fbf5634c9e1ccffe4c5b49f6933c6dd08 SHA512 242e854715e8106261330caa84e1b974d69659d004b21128d666011a3eac226667e3af5ce47b92433262be26a10570adce7dcd79d98970a779d63d962334fdd4
diff --git a/dev-ml/camlpdf/camlpdf-2.1.1.ebuild b/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
new file mode 100644
index 000000000000..e2be0d457ace
--- /dev/null
+++ b/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml library for reading, writing, and modifying PDF files"
+HOMEPAGE="https://github.com/johnwhitington/camlpdf/"
+SRC_URI="https://github.com/johnwhitington/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# technically LGPL-2.1+ with linking exception
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.03.0_beta1' && epatch "${FILESDIR}/ocaml43.patch"
+}
+
+src_compile() {
+ # parallel make bugs
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc Changes README.md
+
+ if use doc ; then
+ dodoc introduction_to_camlpdf.pdf
+ dohtml doc/camlpdf/html/*
+ fi
+
+ use examples && dodoc -r examples
+}
diff --git a/dev-ml/camlpdf/files/ocaml43.patch b/dev-ml/camlpdf/files/ocaml43.patch
new file mode 100644
index 000000000000..86ffbe23eb14
--- /dev/null
+++ b/dev-ml/camlpdf/files/ocaml43.patch
@@ -0,0 +1,13 @@
+Index: camlpdf-2.1.1/flatestubs.c
+===================================================================
+--- camlpdf-2.1.1.orig/flatestubs.c
++++ camlpdf-2.1.1/flatestubs.c
+@@ -170,7 +170,7 @@ value camlzip_inflateEnd(value vzs)
+
+ value camlzip_update_crc32(value crc, value buf, value pos, value len)
+ {
+- return copy_int32(crc32((uint32) Int32_val(crc),
++ return copy_int32(crc32((uint32_t) Int32_val(crc),
+ &Byte_u(buf, Long_val(pos)),
+ Long_val(len)));
+ }
diff --git a/dev-ml/camlpdf/metadata.xml b/dev-ml/camlpdf/metadata.xml
new file mode 100644
index 000000000000..1e93b8f9e9d6
--- /dev/null
+++ b/dev-ml/camlpdf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">johnwhitington/camlpdf</remote-id>
+ </upstream>
+</pkgmetadata>