summaryrefslogtreecommitdiff
path: root/dev-ml/camlp4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/camlp4
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/camlp4')
-rw-r--r--dev-ml/camlp4/Manifest5
-rw-r--r--dev-ml/camlp4/camlp4-4.04_p1.ebuild43
-rw-r--r--dev-ml/camlp4/camlp4-4.05_p1.ebuild43
-rw-r--r--dev-ml/camlp4/metadata.xml11
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-ml/camlp4/Manifest b/dev-ml/camlp4/Manifest
new file mode 100644
index 000000000000..7b9e293dc801
--- /dev/null
+++ b/dev-ml/camlp4/Manifest
@@ -0,0 +1,5 @@
+DIST camlp4-4.04_p1.tar.gz 648320 BLAKE2B d383a366facaaa440b24184bb54a8e1c3bb22ae02387a0bc4f9ee4331ecdc60e5bf22715c1022c987041fb081eb448794a74026736df9f70e05c7213e08bfa44 SHA512 7db8eebcf3d230f60650ba62d9cb630c069394237e97b678a40b61d3dcaded752a2b7e089a50ff528f1ea0740d0291b722df123a072f2cee489cadc5201c6776
+DIST camlp4-4.05_p1.tar.gz 647566 BLAKE2B 068c1016a75616811787eb480b61349a32960997f03e0bc99d63e15357a8932a6019d9e7195541fd942ef99fc1d71c067fb5fcb0fd0c2c3efb77aac494589854 SHA512 0ee9720286d0d832fb7d2d21a8877856e0e47c94c86b1b58d28f8e757a18472eecb56a16e3a04ce815f240dd5048f5d597515461d084fd1cf4da1b121f97a3fe
+EBUILD camlp4-4.04_p1.ebuild 1021 BLAKE2B c1c00019747a1a398578858942462d6e0f9c180ac0cd058a0a87f914ebf53243ff3d21c61dc1802cc1b0a211ab7ce1ac396c6b355c3a639848fc373a0a9821bb SHA512 df3bdaabef1776a2e773f30149084890dddbff843ef9e13b0f3ccee9ca9fb390f6ec1a04c9a1cd4e7b4d0536d6be966dd89f46542dc367a3a030fd10853030bf
+EBUILD camlp4-4.05_p1.ebuild 1030 BLAKE2B 74797690733b8e1fa5ba86f492ae8f3ca15bc08ea6a25c90c7aeaac16fdfb46904c0e0710883d527ed371619790484b6d2f7bdc48baffbcfc1f9498767de17ad SHA512 ba799d8915c54c6d7e4c565505124d76d18aa93f581bcc4292742f239e5cffb951fdd82f549034a17129400e330e91133b43bfd01975fbb25e53193c90d88e5b
+MISC metadata.xml 334 BLAKE2B d60251e891f7bc81e706902964e6bbc05616a75204bc1b13da8f8a7a67e6514b8be0cd3c67775efdb084770e57c28129725b6549a57903c3b5d15f78565b400d SHA512 195b9f2bf651b9f57c1f4333dcb1e0b7766c1d39df2faafcf01b16e4aab28a67e2434c2368d62bff16bf14ea3763d66d0d5a47714ef9f2282cd90d00cc49328f
diff --git a/dev-ml/camlp4/camlp4-4.04_p1.ebuild b/dev-ml/camlp4/camlp4-4.04_p1.ebuild
new file mode 100644
index 000000000000..9a5152d03f33
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-4.04_p1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/ocaml/camlp4"
+SRC_URI="https://github.com/ocaml/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.04_beta:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-lang/ocaml-4.02
+ !<dev-ml/findlib-1.5.5-r1"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S=${WORKDIR}/${P/_p/-}
+
+src_configure() {
+ ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)" \
+ || die
+}
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}
diff --git a/dev-ml/camlp4/camlp4-4.05_p1.ebuild b/dev-ml/camlp4/camlp4-4.05_p1.ebuild
new file mode 100644
index 000000000000..63a829b74226
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-4.05_p1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/ocaml/camlp4"
+SRC_URI="https://github.com/ocaml/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.05_beta:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-lang/ocaml-4.02
+ !<dev-ml/findlib-1.5.5-r1"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S=${WORKDIR}/${P/_p/-}
+
+src_configure() {
+ ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)" \
+ || die
+}
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}
diff --git a/dev-ml/camlp4/metadata.xml b/dev-ml/camlp4/metadata.xml
new file mode 100644
index 000000000000..3cd96568fe64
--- /dev/null
+++ b/dev-ml/camlp4/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/camlp4</remote-id>
+ </upstream>
+</pkgmetadata>