summaryrefslogtreecommitdiff
path: root/dev-ml/camlidl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ml/camlidl/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/camlidl/files')
-rw-r--r--dev-ml/camlidl/files/META.camlidl5
-rw-r--r--dev-ml/camlidl/files/includes.patch12
-rw-r--r--dev-ml/camlidl/files/nowarn.patch13
-rw-r--r--dev-ml/camlidl/files/tests.patch36
4 files changed, 0 insertions, 66 deletions
diff --git a/dev-ml/camlidl/files/META.camlidl b/dev-ml/camlidl/files/META.camlidl
deleted file mode 100644
index b0aeaf231415..000000000000
--- a/dev-ml/camlidl/files/META.camlidl
+++ /dev/null
@@ -1,5 +0,0 @@
-description = "Stub generator"
-version = "@VERSION"
-directory = "^"
-archive(byte) = "com.cma"
-archive(native) = "com.cmxa"
diff --git a/dev-ml/camlidl/files/includes.patch b/dev-ml/camlidl/files/includes.patch
deleted file mode 100644
index 060aceefd0a5..000000000000
--- a/dev-ml/camlidl/files/includes.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: camlidl-1.05/runtime/comerror.c
-===================================================================
---- camlidl-1.05.orig/runtime/comerror.c
-+++ camlidl-1.05/runtime/comerror.c
-@@ -22,6 +22,7 @@
- #include <caml/callback.h>
- #include <caml/fail.h>
- #include <caml/alloc.h>
-+#include <caml/printexc.h>
- #include "camlidlruntime.h"
- #include "comstuff.h"
-
diff --git a/dev-ml/camlidl/files/nowarn.patch b/dev-ml/camlidl/files/nowarn.patch
deleted file mode 100644
index 8b457cf7ed1e..000000000000
--- a/dev-ml/camlidl/files/nowarn.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: camlidl-1.05/compiler/Makefile
-===================================================================
---- camlidl-1.05.orig/compiler/Makefile
-+++ camlidl-1.05/compiler/Makefile
-@@ -29,7 +29,7 @@ PROG=camlidl$(EXE)
- all: $(PROG)
-
- $(PROG): $(OBJS)
-- $(OCAMLC) -o $(PROG) $(OBJS)
-+ $(OCAMLC) -w -a -o $(PROG) $(OBJS)
-
- clean::
- rm -f $(PROG)
diff --git a/dev-ml/camlidl/files/tests.patch b/dev-ml/camlidl/files/tests.patch
deleted file mode 100644
index f7272424be80..000000000000
--- a/dev-ml/camlidl/files/tests.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Index: camlidl-1.05/tests/unix.idl
-===================================================================
---- camlidl-1.05.orig/tests/unix.idl
-+++ camlidl-1.05/tests/unix.idl
-@@ -15,16 +15,16 @@ quote (C, "
-
- union process_status { int code; };
-
-- enum { WEXITED, WSIGNALED, WSTOPPED };
-+ enum { WEXITED2, WSIGNALED, WSTOPPED2 };
-
- static void decode_status(int status, int * kind, union process_status * p)
- {
- if (WIFEXITED(status)) {
-- *kind = WEXITED; p->code = WEXITSTATUS(status);
-+ *kind = WEXITED2; p->code = WEXITSTATUS(status);
- } else if (WIFSIGNALED(status)) {
- *kind = WSIGNALED; p->code = WTERMSIG(status);
- } else {
-- *kind = WSTOPPED; p->code = WSTOPSIG(status);
-+ *kind = WSTOPPED2; p->code = WSTOPSIG(status);
- }
- }
-
-@@ -59,9 +59,9 @@ int execve([in,string] char * path,
- int fork(void);
-
- union process_status {
-- case WEXITED: int code;
-+ case WEXITED2: int code;
- case WSIGNALED: int code;
-- case WSTOPPED: int code;
-+ case WSTOPPED2: int code;
- };
-
- int wait([out] int * kind,