summaryrefslogtreecommitdiff
path: root/dev-ml/camlidl/camlidl-1.05-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ml/camlidl/camlidl-1.05-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/camlidl/camlidl-1.05-r1.ebuild')
-rw-r--r--dev-ml/camlidl/camlidl-1.05-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-ml/camlidl/camlidl-1.05-r1.ebuild b/dev-ml/camlidl/camlidl-1.05-r1.ebuild
deleted file mode 100644
index 6dd3e9f5d3d3..000000000000
--- a/dev-ml/camlidl/camlidl-1.05-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="CamlIDL is a stub code generator for using C/C++ libraries from O'Caml"
-HOMEPAGE="http://caml.inria.fr/camlidl/"
-SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
-LICENSE="QPL-1.0 LGPL-2"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt]"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/tests.patch"
- epatch "${FILESDIR}/includes.patch"
- epatch "${FILESDIR}/nowarn.patch"
-}
-
-src_compile() {
- # Use the UNIX makefile
- libdir=`ocamlc -where`
- sed -i -e "s|OCAMLLIB=.*|OCAMLLIB=${libdir}|" config/Makefile.unix
- sed -i -e "s|BINDIR=.*|BINDIR=${EPREFIX}/usr/bin|" config/Makefile.unix
- ln -s Makefile.unix config/Makefile
-
- # Make
- emake -j1
-}
-
-src_test() {
- einfo "Running tests..."
- cd tests
- emake CCPP="$(tc-getCXX)"
-}
-
-src_install() {
- libdir=`ocamlc -where`
- dodir ${libdir#${EPREFIX}}/caml
- dodir /usr/bin
- # Install
- emake BINDIR="${ED}/usr/bin" OCAMLLIB="${D}${libdir}" install
-
- # Add package header
- sed -e "s/@VERSION/${P}/g" "${FILESDIR}/META.camlidl" > "${D}${libdir}/META.camlidl" || die
-
- # Documentation
- dodoc README Changes
-}