summaryrefslogtreecommitdiff
path: root/dev-ml/camldbm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/camldbm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/camldbm')
-rw-r--r--dev-ml/camldbm/Manifest5
-rw-r--r--dev-ml/camldbm/camldbm-1.0.ebuild28
-rw-r--r--dev-ml/camldbm/files/hasgotfix.patch15
-rw-r--r--dev-ml/camldbm/files/include_fix.patch15
-rw-r--r--dev-ml/camldbm/metadata.xml8
5 files changed, 71 insertions, 0 deletions
diff --git a/dev-ml/camldbm/Manifest b/dev-ml/camldbm/Manifest
new file mode 100644
index 000000000000..f97ccb849a7a
--- /dev/null
+++ b/dev-ml/camldbm/Manifest
@@ -0,0 +1,5 @@
+AUX hasgotfix.patch 418 BLAKE2B f8f5a728cb1fa772db368faf3bfb6047fa570d0845155caff5d22e40b3a82d33b33844cf405ceb2021bfb5c3ec641cf59a0afe2546657cedc0f33c120b525c10 SHA512 3b936694976c962540734bcca51a762cd3a02f6d1d4678eeeb2c4ee283bd0defa0dcea90dc062475dbd542efe871041b7a76782b0437d34b682914b8f39a042d
+AUX include_fix.patch 512 BLAKE2B e99ff15b037c2db639f14ff234c51c2a34c7dc2a5c3395d58675c89c240e2f9928913f38956a70d87f7d6f522937f1f51a9f77d245f095df8ddb0c0a988c285f SHA512 46a05033c469ec8b668e044a799d230b82539e2bb43067383f89f46f9ac128a2b43e8a5439dda16e368f283c608d6561109389d2aab3c8cdde7fbdb957433cad
+DIST camldbm-1.0.tgz 14397 BLAKE2B 9b6971e30815ad6984254591af793819beb3859ddbf7bbd95ee744a2b09ce04968ecad9c7ff954e1606776d82988b3499f2569154586a937a61eb6d5c7b9465b SHA512 d0b752754650efb400f13f957e83fddccf1fc9ac9e1d11f453af94e9aa599546a316eb110685b3728b593c99cbf859cdc7bcf924c878cf8b6dead3dc413ccfbf
+EBUILD camldbm-1.0.ebuild 825 BLAKE2B cd246803cf07acfce7d1fb8661d3a47a91f1d9a0c4fc1688a9358d5db0dac1052c7f83551b2b3aeb517c6af9bc7680ed66ed57b1df3f4445adbfb57585a50bc1 SHA512 b784edb1421a8dce8243cde57197ee152a95080d6b33cadc31ecdab0d5b92449c4d251eaa3c72dbd86b0a4f5dfd736466bcdcbbab09328013b4d6a784a35d580
+MISC metadata.xml 243 BLAKE2B 010ca240ae06e9a9f6d7ba213eb06df36d9ba862ff2d2458d98a9fea1a1e7f3026d13832a73bce1b3ad9345029425e6abfae9e03bf126f2329b3f030ed3753fd SHA512 1c5b4b2163017e496999d1f87e5c9c5ac6c11b2e9187450ccfb3df258f34e54d278972f04ee0e8429476c6f87e091a869ac2a28c6e8c8e6d20678c3e74061449
diff --git a/dev-ml/camldbm/camldbm-1.0.ebuild b/dev-ml/camldbm/camldbm-1.0.ebuild
new file mode 100644
index 000000000000..94941d452955
--- /dev/null
+++ b/dev-ml/camldbm/camldbm-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit base
+
+DESCRIPTION="OCaml binding to the NDBM/GDBM Unix databases"
+HOMEPAGE="http://forge.ocamlcore.org/projects/camldbm/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/728/${P}.tgz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm ppc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="|| ( >=sys-libs/gdbm-1.9.1-r2[berkdb] <sys-libs/gdbm-1.9.1-r2 )
+ >=dev-lang/ocaml-3.12:=[ocamlopt]
+ !<dev-lang/ocaml-4[gdbm]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/hasgotfix.patch" "${FILESDIR}/include_fix.patch" )
+
+src_install() {
+ dodir "$(ocamlc -where)/stublibs" # required and makefile does not create it
+ emake LIBDIR="${D}/$(ocamlc -where)" install
+ dodoc README Changelog
+}
diff --git a/dev-ml/camldbm/files/hasgotfix.patch b/dev-ml/camldbm/files/hasgotfix.patch
new file mode 100644
index 000000000000..840ffcbe7f0f
--- /dev/null
+++ b/dev-ml/camldbm/files/hasgotfix.patch
@@ -0,0 +1,15 @@
+https://forge.ocamlcore.org/tracker/index.php?func=detail&aid=1202&group_id=278&atid=1189
+
+Index: camldbm-1.0/configure
+===================================================================
+--- camldbm-1.0.orig/configure
++++ camldbm-1.0/configure
+@@ -35,7 +35,7 @@ hasgot() {
+ ${CC:-cc} -I$1 -o hasgot.exe hasgot.c $3 $4
+ res=$?
+ rm -f hasgot.c hasgot.exe
+- return $?
++ return $res
+ }
+
+ dbm_include="not found"
diff --git a/dev-ml/camldbm/files/include_fix.patch b/dev-ml/camldbm/files/include_fix.patch
new file mode 100644
index 000000000000..16fb6bd1e96e
--- /dev/null
+++ b/dev-ml/camldbm/files/include_fix.patch
@@ -0,0 +1,15 @@
+https://forge.ocamlcore.org/tracker/index.php?func=detail&aid=1201&group_id=278&atid=1189
+
+Index: camldbm-1.0/Makefile
+===================================================================
+--- camldbm-1.0.orig/Makefile
++++ camldbm-1.0/Makefile
+@@ -51,7 +51,7 @@ libcamldbm.$(A): cldbm.$(O)
+ $(OCAMLOPT) -c $(COMPFLAGS) $<
+
+ .c.$(O):
+- $(OCAMLC) -c -ccopt "$(DBM_INCLUDE)" -ccopt "$(DBM_DEFINES)" $<
++ $(OCAMLC) -c -ccopt "$(DBM_INCLUDES)" -ccopt "$(DBM_DEFINES)" $<
+
+ depend:
+ $(OCAMLDEP) *.ml *.mli > .depend
diff --git a/dev-ml/camldbm/metadata.xml b/dev-ml/camldbm/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/camldbm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>