summaryrefslogtreecommitdiff
path: root/dev-ml/camlbz2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/camlbz2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/camlbz2')
-rw-r--r--dev-ml/camlbz2/Manifest3
-rw-r--r--dev-ml/camlbz2/camlbz2-0.6.0.ebuild30
-rw-r--r--dev-ml/camlbz2/metadata.xml8
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/camlbz2/Manifest b/dev-ml/camlbz2/Manifest
new file mode 100644
index 000000000000..40686403e805
--- /dev/null
+++ b/dev-ml/camlbz2/Manifest
@@ -0,0 +1,3 @@
+DIST camlbz2-0.6.0.tar.gz 57771 BLAKE2B 5b4337ca547c37f6982c29c9b70f00ca3100983541a80bf16e8d549c2eabf64ef917ea3ba445c8bb5bbcdb1a652cc5cd586c95299d194a7abe8e68ea9f1a0599 SHA512 1052536bb08c9d9f9bdf4a063a5a01389445b55117ce423dd1732de00cd79db5e4befb4ce5c81c5db8a6d40b28a2ac4b897bb00598fdccf76ea92a2966592680
+EBUILD camlbz2-0.6.0.ebuild 645 BLAKE2B f40fb6ee805b2e07807a199db36d9f7148738e14942734039aec433fa347aeb79e1842b66343998b3c8665d7783d2b6d80d425d9fd24f506393791ed67b38aa1 SHA512 ad7b303c71c3c94f91b71849dc74c3ceb3294052d017dd87fc485ad69531774df34565ef37dadf43e57f7eacdc70fd977e2b27e5a98f91223d54dd52c617d2ed
+MISC metadata.xml 243 BLAKE2B 010ca240ae06e9a9f6d7ba213eb06df36d9ba862ff2d2458d98a9fea1a1e7f3026d13832a73bce1b3ad9345029425e6abfae9e03bf126f2329b3f030ed3753fd SHA512 1c5b4b2163017e496999d1f87e5c9c5ac6c11b2e9187450ccfb3df258f34e54d278972f04ee0e8429476c6f87e091a869ac2a28c6e8c8e6d20678c3e74061449
diff --git a/dev-ml/camlbz2/camlbz2-0.6.0.ebuild b/dev-ml/camlbz2/camlbz2-0.6.0.ebuild
new file mode 100644
index 000000000000..15884ba324e3
--- /dev/null
+++ b/dev-ml/camlbz2/camlbz2-0.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="OCaml bindings for libbz (AKA, bzip2)"
+HOMEPAGE="http://camlbz2.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/72/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/bzip2
+ >=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${OCAMLFIND_DESTDIR}" install
+ dodoc ChangeLog README ROADMAP BUGS
+ use doc && dohtml doc/*
+}
diff --git a/dev-ml/camlbz2/metadata.xml b/dev-ml/camlbz2/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/camlbz2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>