summaryrefslogtreecommitdiff
path: root/dev-ml/atd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/atd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/atd')
-rw-r--r--dev-ml/atd/Manifest7
-rw-r--r--dev-ml/atd/atd-1.12.0.ebuild46
-rw-r--r--dev-ml/atd/atd-1.2.0.ebuild33
-rw-r--r--dev-ml/atd/atd-1.2.1.ebuild34
-rw-r--r--dev-ml/atd/metadata.xml11
5 files changed, 131 insertions, 0 deletions
diff --git a/dev-ml/atd/Manifest b/dev-ml/atd/Manifest
new file mode 100644
index 000000000000..ffb11febbe26
--- /dev/null
+++ b/dev-ml/atd/Manifest
@@ -0,0 +1,7 @@
+DIST atd-1.12.0.tar.gz 145428 BLAKE2B d9cc3b98567383e1a5dbb068165f144fb033e17030f979eb20963837b96f93d9b950943d59d1d0f348fed28ec05c5906ce6672f848d428193379670f5c4b51c4 SHA512 c24601b276da7837bc896bb42b2e0fa91ebfbf07759560c2490ed44bef722dcf8d586aaba1e62abff262805cab89996835611ab9fb68aa096dfc84bb55365475
+DIST atd-1.2.0.tar.gz 41300 BLAKE2B 3919de0a2ca5b071d2cfdab8b74c6f528bc6c1b6965e6a29d8ddfda89ac6db0fd2b6e1012e052370a9ca555c392176f68339c193076b082c79ebbedcd4146817 SHA512 a52824c9784ac0f4d6f314972fa1d92be14730de3c6bde04032004579ac27408385bd4fa7d926f9d564657eb62050fd732a032f364bada62a1dc7a8acfacb727
+DIST atd-1.2.1.tar.gz 39018 BLAKE2B 313a3019428f187051209e8eb2bec99f9a8fdefdb4da342c50bd54b42378c0c5eda988e13413c567765f8504ee24599fc440fdad6b8a3e728189df0f3b9f1939 SHA512 5dde8dd1e6ca53ae2ff7efc873211079678a824ae7a9d4182d58e3e10ce50a9dcd705de7168a8cfb12ea3d030a0d01b2485d436e77bfa48c14df7628b47161dc
+EBUILD atd-1.12.0.ebuild 840 BLAKE2B b8de319b91b3a4bbe8c6d2f105e249575c531035e2330b35597f1172bf26cfe009fa76a210fca056b912755f0272416b1a029f7900cffdff50817b35cc18a792 SHA512 99c118a0ac6c6803a0bccc3b427b1dc292b2ba685bf59867b281919c129b14cddb603c9fbd7047acbba0d3cbd6ed652b239d57aeb4b2e8a9871f1e2fe45635c6
+EBUILD atd-1.2.0.ebuild 650 BLAKE2B 3122850c5263af96ddffe9672d5340d4a2bd9b6e261acb094cf5de2c8e7daabbe94014b8865113c1e42fdb0b389dc0b5064c4fe8bf5c9f24d24643bb77db2958 SHA512 727734e5c910ee7bd17fda58fa7135a82310ecab74854d6b2e854a85eed233baf8ee65909140907a0e86ad4fe2ec44f11bcdbfb183412c7eb83c5b8acc5c0c14
+EBUILD atd-1.2.1.ebuild 713 BLAKE2B 93dafa58ebd8b668e62cfe8c0af994f33324e423fc0914fda3bc6f9162f699c26d3e472542713cccf48903a2bde71fa73f367ab32e37af638b07b40018e745a9 SHA512 836c383552787eedb784c28069e82b07560d544c3c809c610a3d5ac46d4e35b88ead5e6f0fcb42d8678090a295cdf6c7ef7a42b38d81e2faecaf269fc0407377
+MISC metadata.xml 323 BLAKE2B 19ee0e4526b8d238a43ba6ac3d596896ea04d48289b961a284114e28c61b3ca967aa817c7d6bc0d001a4328896e46a12af6ff5709e4a6605699926c80bf4d980 SHA512 2a41feb51b979c76edda9a13dbb6ff48301387ccf0fdcf4225b49cab80c2d68b87caf463659619a41b9ed253b6cb76d6c392ea88e35b0083aa2849545701830d
diff --git a/dev-ml/atd/atd-1.12.0.ebuild b/dev-ml/atd/atd-1.12.0.ebuild
new file mode 100644
index 000000000000..5095732e9dd9
--- /dev/null
+++ b/dev-ml/atd/atd-1.12.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Syntax for cross-language type definitions"
+HOMEPAGE="https://github.com/mjambon/atd"
+SRC_URI="https://github.com/mjambon/atd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+ dev-ml/menhir:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? (
+ dev-ml/biniou
+ dev-ml/yojson
+ )
+"
+
+src_compile() {
+ jbuilder build -p atd || die
+}
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${1}.install || die
+}
+
+src_install() {
+ oinstall atd
+}
diff --git a/dev-ml/atd/atd-1.2.0.ebuild b/dev-ml/atd/atd-1.2.0.ebuild
new file mode 100644
index 000000000000..8f343658f391
--- /dev/null
+++ b/dev-ml/atd/atd-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Syntax for cross-language type definitions"
+HOMEPAGE="https://github.com/mjambon/atd"
+SRC_URI="https://github.com/mjambon/atd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+ dev-ml/menhir:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1 all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ dodir /usr/bin
+ PREFIX="${ED}/usr" findlib_src_install
+ dodoc README.md
+}
diff --git a/dev-ml/atd/atd-1.2.1.ebuild b/dev-ml/atd/atd-1.2.1.ebuild
new file mode 100644
index 000000000000..d57bf461c6d4
--- /dev/null
+++ b/dev-ml/atd/atd-1.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Syntax for cross-language type definitions"
+HOMEPAGE="https://github.com/mjambon/atd"
+SRC_URI="https://github.com/mjambon/atd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+ dev-ml/menhir:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/atd/metadata.xml b/dev-ml/atd/metadata.xml
new file mode 100644
index 000000000000..42629fd4a5b4
--- /dev/null
+++ b/dev-ml/atd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mjambon/atd</remote-id>
+ </upstream>
+</pkgmetadata>