summaryrefslogtreecommitdiff
path: root/dev-ml/atd/atd-2.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-03 03:56:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-03 03:56:37 +0000
commit54e9f9704b37e05c561eadb37d89d30ee7dda9ee (patch)
treebb03a8b10fc448608096c5e872d62b366fc2c93c /dev-ml/atd/atd-2.15.0.ebuild
parent1615d14d4de4360b2241ce5cd8a84157cc86cde0 (diff)
gentoo auto-resync : 03:11:2023 - 03:56:37
Diffstat (limited to 'dev-ml/atd/atd-2.15.0.ebuild')
-rw-r--r--dev-ml/atd/atd-2.15.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/atd/atd-2.15.0.ebuild b/dev-ml/atd/atd-2.15.0.ebuild
new file mode 100644
index 000000000000..8cbc489b2d4c
--- /dev/null
+++ b/dev-ml/atd/atd-2.15.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Static types for JSON APIs"
+HOMEPAGE="https://github.com/ahrefs/atd/"
+SRC_URI="https://github.com/ahrefs/atd/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08:=[ocamlopt?]
+ >=dev-ml/cmdliner-1.1.1:=
+ >=dev-ml/yojson-2.0.2:=
+ dev-ml/biniou:=
+ dev-ml/easy-format:=
+ dev-ml/menhir:=
+ dev-ml/re:=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dune-install atd \
+ atdgen \
+ atdgen-codec-runtime \
+ atdgen-runtime \
+ atdj \
+ atdpy \
+ atds \
+ atdts
+
+ dodoc CHANGES.md CONTRIBUTING.md README.md
+}