summaryrefslogtreecommitdiff
path: root/dev-ml/async_unix/async_unix-0.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-ml/async_unix/async_unix-0.14.0.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-ml/async_unix/async_unix-0.14.0.ebuild')
-rw-r--r--dev-ml/async_unix/async_unix-0.14.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/async_unix/async_unix-0.14.0.ebuild b/dev-ml/async_unix/async_unix-0.14.0.ebuild
new file mode 100644
index 000000000000..e57bd57ede02
--- /dev/null
+++ b/dev-ml/async_unix/async_unix-0.14.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library (unix)"
+HOMEPAGE="https://github.com/janestreet/async_unix"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/async_kernel:=
+ dev-ml/core:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_jane:=
+"
+DEPEND="${RDEPEND}"