summaryrefslogtreecommitdiff
path: root/dev-ml/async_ssl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-ml/async_ssl
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-ml/async_ssl')
-rw-r--r--dev-ml/async_ssl/Manifest2
-rw-r--r--dev-ml/async_ssl/async_ssl-0.9.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/async_ssl/Manifest b/dev-ml/async_ssl/Manifest
index 1214602da143..9c6ebbde4c11 100644
--- a/dev-ml/async_ssl/Manifest
+++ b/dev-ml/async_ssl/Manifest
@@ -1,3 +1,5 @@
DIST async_ssl-0.9.0.tar.gz 28227 BLAKE2B e916e196964d085312836d773e290ac52c950c5ceb084347557d72776c7b6b9548ad2bd01c5fc6fa701d18c55fff62e48af5459bf5897478252f8d27dd6687fc SHA512 bb023e0c60f9f04368f2e2a4aea80700a60853a03fe1550fe48a9defe42ec66736a6cc0cf40c6a472cd3f8b5b30d79711e4fd714b53ebd4ba7f3f3c22eb7a15e
+DIST async_ssl-0.9.1.tar.gz 28162 BLAKE2B 74987fcad26dcb641687e044ef76531cfa88e2bb62524d0eddf5ce3fe4f4dc9c7b07f13de63e9cdddd4a5db2e7e20f2a7f3a8543b17678a342e2890ed816189a SHA512 5e20d3c2a46e81d725076a80347047de90d00d6a0956457656ffd629d80b7a65958fd8a831d407dd11e3a3583662ed1e04242e71580ab7e982dc579ee69bface
EBUILD async_ssl-0.9.0.ebuild 822 BLAKE2B 692e29784084f17383eb728ea5d3eab3bacaf353397bfaacdddf5115d70b1ef68ef2678d905f0b6ea18fd5d4881b36033a6f2230f654d4dbf044d24259743981 SHA512 1b3f7d070cc0d6b09c139e4c467f6dc5c748c5ccc1b756c9590fc7ffe3237e4a35623f462e2767178dabf504471d1511e71e44478927a58e9c663a6e69b45459
+EBUILD async_ssl-0.9.1.ebuild 819 BLAKE2B be275f56a8a2308d3495668bc661f27bc3aa90c1fddb48559bc71594b946a133c2810112085e87d7187e99228bb3cdc711dc41b99f9fb760a36e5270da1952ed SHA512 0f3d4d34c7d954fcae46cc88d9e24f0b7d0cc2cec58196ff723f486b83956e24e4240035f90aab320dc2288c4f464e0fd32ea9f845634b1c71d26abebec40348
MISC metadata.xml 332 BLAKE2B 82d2502af15abffa019c5d0665eceb4270ed2a30080763a301e3609a9e5cebcb15cb36f9019c427f86955927ea008f8e754bf931a1179dd7974ef321a74747e5 SHA512 1d5dbdca3ca70a23e287169f7e4d8bcfc8912ce7713a349c90a04375874e9fdc948232ad314c4a3cc7b4109d6b42100804758126b202d8a952a3a0761a083dd0
diff --git a/dev-ml/async_ssl/async_ssl-0.9.1.ebuild b/dev-ml/async_ssl/async_ssl-0.9.1.ebuild
new file mode 100644
index 000000000000..aece7ea02729
--- /dev/null
+++ b/dev-ml/async_ssl/async_ssl-0.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An Async-pipe-based interface with OpenSSL."
+HOMEPAGE="https://github.com/janestreet/async_ssl"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/async:=
+ dev-ml/base:=
+ dev-ml/configurator:=
+ dev-ml/core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-ctypes:=
+ dev-libs/openssl:0=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ dev-ml/jbuilder
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}