summaryrefslogtreecommitdiff
path: root/dev-lua
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-11 04:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-11 04:37:21 +0100
commitf8d2edf76d3901ebc1ace32c33a4d547fd5eee63 (patch)
tree742aed438164cbd07e8b218247c5519dd17d8749 /dev-lua
parent783da4542a9c3e0e1ec703644212707cde610679 (diff)
gentoo auto-resync : 11:09:2023 - 04:37:21
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/Manifest.gzbin7313 -> 7314 bytes
-rw-r--r--dev-lua/luv/Manifest2
-rw-r--r--dev-lua/luv/luv-1.45.0.0.ebuild86
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-lua/Manifest.gz b/dev-lua/Manifest.gz
index f2beccfff69c..ef7d2343b8ec 100644
--- a/dev-lua/Manifest.gz
+++ b/dev-lua/Manifest.gz
Binary files differ
diff --git a/dev-lua/luv/Manifest b/dev-lua/luv/Manifest
index 379c4257f4bb..0f492aea4d17 100644
--- a/dev-lua/luv/Manifest
+++ b/dev-lua/luv/Manifest
@@ -1,5 +1,7 @@
AUX luv-1.43.0.0-cmake_lua_version.patch 458 BLAKE2B 39e8f045b261f2a2acfb86b3cb5c1ee875fc44061e59b00e3addc6ca2437be3c2279176908d2f9500a4728fd8d0d786d2903935a8048398e1e6580a462ee63ad SHA512 cbfff6f4ed3ceed5fb14205c512baa6e2c6d424f5b4998bcc4db6ed776eabe87e5b7ccf69ec75cbb3336908831f0cf908dd6cefd0d1d540c2dc2bdb8c5b0d660
DIST luv-1.44.2.0.tar.gz 124180 BLAKE2B 0a46ffccd67bf04fb60c7aa3685fef328da1323437640a04b36748680aaf4074300097c53206915d8a1133defc61a359cd88062f1661899dfa8c394c183f0d0d SHA512 0744590de941ec67e23e04811ed28de5e5ed8b6dd0d45e52e8e0efe0551d007f28cdada8e0d69e0d59bd37d4026102271a8ef977b12cfac1e84f6c8b57e6adce
+DIST luv-1.45.0.0.tar.gz 130334 BLAKE2B f22f6705204db567de7943707b499897fbd51cf33c6bc571612e0682f3b6022d6dd56606df0ff850e72bde398f00c4db00c026f1b8de5182458b39095716cbd7 SHA512 50460573377bc9386a90aa75f7d4938571b04f74ca6f63e32fa2b2f8951e799465abb78b4270f22be511c4d328ce582c38ec3e3da1061310fcfee630b647854d
DIST luv-lua-compat-0.10.tar.gz 53695 BLAKE2B e570aedb23b8ed7ca38c4316ffab25b93a0f9f6f0fae79af563ca8a81dd6453ac273e1f9e70674c484a2dec68749e7d53a1c1736a72616c210b8e38a31b3f191 SHA512 f7f39085f4f6b16095f41e635b4c5477b3dab5e42b5b65a9d522941a3807ea521d4a27a77293a3c9d0ecea78a1f6c2a2497394b2d220f4d7d65e23510563d46d
EBUILD luv-1.44.2.0.ebuild 2317 BLAKE2B 6c8f7782608e7f8b88247f73f1598f09337de0931e82da87f6f9f59ea05b5bb7f9172d3ce45a7c6531efa2d6641dce7d261c73aad4447220e4cbc024b340810a SHA512 f669281040b730081601dfa73a88bdd5ce1b933b4762b778cd1102e19c541231c226f939e096a6bd5b318c177eaf4447012155fc070818d2d8c5d4d367ee957a
+EBUILD luv-1.45.0.0.ebuild 2320 BLAKE2B cdf7f345080c30a3b9cef3af596b259dea203c7093e145270a9dc7a7ef67ca49a7717cfe863286f91327e7de87a17764a3672f8aff16ef10740c7525e9414113 SHA512 409e405f2ff040bf0af07c2b197d103f47c22012200ff367155fa75e92d9cca3ccf6ddf2c724986db0732f0a79296d23e9584e82ce7e144d5b4591d9f25bdbf8
MISC metadata.xml 484 BLAKE2B eb035fd19fe978128b6742025f44fc233348a496de2628c80f67db2ae64717e4a3685eec1456f920052e406d15855e225987389a4e33d7caaa5b938418849ecf SHA512 4bf472b91b176e1af730ffb84fade9ab49590726107c73f6c37dac491df394b6779a50e658d062b1cedc0a05f1fb89463817945bc075df572e3e9d6adab04a2f
diff --git a/dev-lua/luv/luv-1.45.0.0.ebuild b/dev-lua/luv/luv-1.45.0.0.ebuild
new file mode 100644
index 000000000000..8d24ac375d6d
--- /dev/null
+++ b/dev-lua/luv/luv-1.45.0.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit cmake flag-o-matic lua-single unpacker
+
+# e.g. MY_PV = a.b.c-d
+MY_PV="$(ver_rs 3 -)"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Bare libuv bindings for lua"
+HOMEPAGE="https://github.com/luvit/luv"
+
+LUA_COMPAT_PV="0.10"
+SRC_URI="
+ https://github.com/luvit/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/keplerproject/lua-compat-5.3/archive/v${LUA_COMPAT_PV}.tar.gz -> ${PN}-lua-compat-${LUA_COMPAT_PV}.tar.gz
+"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="${LUA_DEPS}
+ >=dev-libs/libuv-$(ver_cut 1-2):="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.43.0.0-cmake_lua_version.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix libdir
+ # Match '/lib/' and '/lib"' without capturing / or ", replacing with libdir
+ sed -i -r "s/\/lib(\"|\/)/\/$(get_libdir)\1/g" CMakeLists.txt || die "Failed to sed CMakeLists.txt"
+ cmake_src_prepare
+}
+
+# This could in theory be multi-impl (and we have an ebuild in git history,
+# 1.32.0.0-r101, which implements it) - the only revdep currently in the tree,
+# app-editors/neovim, actually links against luv instead of trying to load it
+# as a module. We could probably implement some sort of a hack for this
+# - but given how messy it would be, don't bother unless someone actually requests
+# luv multi-impl support.
+src_configure() {
+ lua_compat_dir="${WORKDIR}/lua-compat-5.3-${LUA_COMPAT_PV}"
+
+ local mycmakeargs=(
+ -DBUILD_MODULE=OFF
+ -DLUA_BUILD_TYPE=System
+ -DLUA_COMPAT53_DIR="${lua_compat_dir}"
+ -DWITH_SHARED_LIBUV=ON
+ )
+ if [[ ${ELUA} == luajit ]]; then
+ mycmakeargs+=(
+ -DWITH_LUA_ENGINE=LuaJIT
+ )
+ else
+ mycmakeargs+=(
+ -DWITH_LUA_ENGINE=Lua
+ -DLUA_VERSION=$(ver_cut 1-2 $(lua_get_version))
+ )
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ append-ldflags "-undefined dynamic_lookup"
+ fi
+
+ cmake_src_configure
+}
+
+src_test() {
+ # We need to copy the library back so that the tests see it
+ ln -s "${BUILD_DIR}/libluv.so" "./luv.so" || die "Failed to symlink library for tests"
+ ${ELUA} "tests/run.lua" || die "Tests failed"
+}