summaryrefslogtreecommitdiff
path: root/dev-lua
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-26 10:30:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-26 10:30:48 +0100
commit96cc0713998c294a9440f03dfa8c4adc9cb71f92 (patch)
treec51c399e2ac466345931e32f9bb465534a74f828 /dev-lua
parent390bde0d9e0b055c7e87ede2f6b3546ec7da02c7 (diff)
gentoo auto-resync : 26:07:2023 - 10:30:48
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/Manifest.gzbin7302 -> 7304 bytes
-rw-r--r--dev-lua/lutok/Manifest3
-rw-r--r--dev-lua/lutok/lutok-0.4-r11.ebuild53
-rw-r--r--dev-lua/lutok/metadata.xml3
4 files changed, 58 insertions, 1 deletions
diff --git a/dev-lua/Manifest.gz b/dev-lua/Manifest.gz
index 9094d78e4b22..59837e124ef9 100644
--- a/dev-lua/Manifest.gz
+++ b/dev-lua/Manifest.gz
Binary files differ
diff --git a/dev-lua/lutok/Manifest b/dev-lua/lutok/Manifest
index b0ba4c428c2e..e93dfd112d2a 100644
--- a/dev-lua/lutok/Manifest
+++ b/dev-lua/lutok/Manifest
@@ -1,3 +1,4 @@
DIST lutok-0.4.tar.gz 489570 BLAKE2B b4bc26d9a4901901e6ca66a41bc42ccc2f82697ff14e64c1bea35b4a9ed08b6f13ecfa9aaabb54e25fb3e4f3aea03791c225c4c8fc6ed3e0387d34d933a228e9 SHA512 664f30099bfbb30978e24068a9232a4ff1b5b1839c601bf784f35f6bb1394558067495093a3b0343c94e756d2e4186a32a8227baf5934c15c45905f7c0a5d19c
EBUILD lutok-0.4-r10.ebuild 975 BLAKE2B 5abeb0c4c1c30cf464f996c7ad85451fafdeea8e299444e588c462a3d9e77b3131897d1cc136f8f225844fe3142a1fe139d0bcb075e0b1faee6279e0eb1c1fa2 SHA512 906bedeb278523eaddbe7f1e8ba1e3a9121fe02c4c742205029039c73423a41591c986e8beb5121b214663ada6adfa5821d826b5ca989e20a35bb755c8bfbf1b
-MISC metadata.xml 247 BLAKE2B 9dcf90d404c84f0ce3da367274c25984b6497a2d8fb68496f497e76c7061c9c7ca7f444f7e4ccb62ba06223caaf0eea4d6aebbb2409ba1f08bb57123e72f0836 SHA512 4681b02c210bf3f869157694af1f80cb3e9b2dd619283a249aaafa85d3bc328c1306af5d61c69040fc503feb3271490bdd2e38e61479a94940fa225810b9e8cb
+EBUILD lutok-0.4-r11.ebuild 1132 BLAKE2B 400852cb23ead01890bbf6d182e2bcafce3512fbcab9632fd9ac8a724a51e590843cb847ec17289788fce4cdca3dd031c47db866edbdca4b245b1c02b9dd117c SHA512 abc7ca7e08c87d1329b28a49fa0f1de12fe94a2220ff1bb2bb129ab7068abf1e3d5cc68c4ced769293255771dc083bdd8420eac4c01c17401daba351906672c2
+MISC metadata.xml 322 BLAKE2B b0d43a21c8b8360db9c6fbe1179c0ad211f23ce0ae083aba21d92c155c19e09337cd10f5cbe2b02b9f9fdd43e3fc03e4979df89977eff5234c38f56e74e34006 SHA512 917c5031f80ffd6e4ef1cd994d03d60a068effd7ade96ddb103f152d07ce5cab787cd35e120f5195155e0e1164e8f2a3eca912c47652ea7288ce7c14ed433ec3
diff --git a/dev-lua/lutok/lutok-0.4-r11.ebuild b/dev-lua/lutok/lutok-0.4-r11.ebuild
new file mode 100644
index 000000000000..c3e30ece373f
--- /dev/null
+++ b/dev-lua/lutok/lutok-0.4-r11.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2017-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single
+
+DESCRIPTION="Lightweight C++ API library for Lua"
+HOMEPAGE="https://github.com/jmmv/lutok"
+SRC_URI="https://github.com/jmmv/lutok/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-libs/atf
+ dev-util/kyua
+ )
+"
+DEPEND="${LUA_DEPS}"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ :
+}
+
+src_configure() {
+ # Uses std::auto_ptr (deprecated in c++11, removed in c++17)
+ # <https://github.com/jmmv/lutok/issues/7>
+ export CXXFLAGS="-std=c++14 ${CXXFLAGS}"
+
+ lua_setup
+ local myconf=(
+ --enable-shared
+ --disable-static
+ LUA_CFLAGS="$(lua_get_CFLAGS)"
+ LUA_LIBS="$(lua_get_LIBS)"
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/tests || die
+ find "${ED}" -name '*.la' -type f -delete || die
+}
diff --git a/dev-lua/lutok/metadata.xml b/dev-lua/lutok/metadata.xml
index 077cdb6aa203..bc13b48c8dd3 100644
--- a/dev-lua/lutok/metadata.xml
+++ b/dev-lua/lutok/metadata.xml
@@ -5,4 +5,7 @@
<email>floppym@gentoo.org</email>
<name>Mike Gilbert</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">jmmv/lutok</remote-id>
+ </upstream>
</pkgmetadata>