summaryrefslogtreecommitdiff
path: root/dev-lua
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-lua
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/Manifest.gzbin6323 -> 6322 bytes
-rw-r--r--dev-lua/luasocket/Manifest2
-rw-r--r--dev-lua/luasocket/files/proxy-fix.patch31
-rw-r--r--dev-lua/luasocket/luasocket-3.0_rc1-r4.ebuild55
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-lua/Manifest.gz b/dev-lua/Manifest.gz
index a3482f37370a..208539425a2e 100644
--- a/dev-lua/Manifest.gz
+++ b/dev-lua/Manifest.gz
Binary files differ
diff --git a/dev-lua/luasocket/Manifest b/dev-lua/luasocket/Manifest
index 7f88682a9313..aef4b94a305b 100644
--- a/dev-lua/luasocket/Manifest
+++ b/dev-lua/luasocket/Manifest
@@ -1,3 +1,5 @@
+AUX proxy-fix.patch 1026 BLAKE2B 6dde53833c9b35e059a4c1e7052cb494b4e1ceb2dc496a2d090e80fc2a1bfd1a30d014bb4c9f04425665cc00faa29fd434077a13e54cb73af0699363602e3aab SHA512 8b1b440936eceea4352876b24099bd9250c28c78a104f3722a65690a756f831f025257d940f1d9189e8ac023ab4b226b16c901214de59306bac96353a5adfe12
DIST luasocket-3.0_rc1.tar.gz 328598 BLAKE2B 9cc382d909cfa018edec237ac901220cccb0cf0e3a775b9cd8083487ace42a94dfd280f9423097f677f37ee9f85afcfff844250cd49c0f813b7c50c3adc532c5 SHA512 f6efce259aaacaa11472911471f8a13b118fe009b8953a82c6aa18b9ec829cd1293180904e56935cb130d36d267e3f27c91db2d78e03f7488f3e100571ed0540
EBUILD luasocket-3.0_rc1-r3.ebuild 1107 BLAKE2B d7a6263f58f3db82491a132ce44e033c9db857eaedbafe3b015be1bff86073c58b932c072d2cf3c213e6a5bd003b0267cfa7ab6ef2e73c22aa402b379a20b73a SHA512 f85177c0f36e3dec2c7c2a92d0d31034877214bf4cb848901b04868321e5fed64b6b2b123dce3815be0f726975a3a074647f2fafd9dff893212bdc2a76a8f631
+EBUILD luasocket-3.0_rc1-r4.ebuild 1180 BLAKE2B 724ac52f5a7b5dc7c36bb7135af260a8d2e50b4ddcb02da88474149f0982c7b79b7f18a754242a14e6102470cfad091e6a287d5b671b1850e5553307b1f53eee SHA512 940e09c9275f326cebb3b49b4ea39cbec17bce94c52a1c362fbadd07b0169cb703063d817c825d3f7f272aa1529e63db76fbe193a5420abeee3b95db87cf97e0
MISC metadata.xml 257 BLAKE2B e834a8237ad7c56f7e94a41c634fd0bb34b3c6e21b04ecafb2394839ee3bec0b0d5ee3cdcb43f358894156aacbdc6566092e6f1a4034573b117cba3368214b97 SHA512 a14f4fdf4826065cc3c5bba386e790d97d31a4e5eb042d269bdc56c9d6122bd2d3322971a6ce7431e860538af861e675a57afd9fa100e63d6c35d36c68aacf7e
diff --git a/dev-lua/luasocket/files/proxy-fix.patch b/dev-lua/luasocket/files/proxy-fix.patch
new file mode 100644
index 000000000000..302e63663ff7
--- /dev/null
+++ b/dev-lua/luasocket/files/proxy-fix.patch
@@ -0,0 +1,31 @@
+From 1f9ccb2b586c3a7e29db3c99a23ac1cee6907cf2 Mon Sep 17 00:00:00 2001
+From: Pierre Chapuis <catwell@archlinux.us>
+Date: Fri, 5 Jul 2013 18:00:29 +0200
+Subject: [PATCH] http: look for PROXY in _M, not as a global
+
+---
+ src/http.lua | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/http.lua b/src/http.lua
+index 5f70a374..f83dcc55 100644
+--- a/src/http.lua
++++ b/src/http.lua
+@@ -186,7 +186,7 @@ end
+ local function adjusturi(reqt)
+ local u = reqt
+ -- if there is a proxy, we need the full url. otherwise, just a part.
+- if not reqt.proxy and not PROXY then
++ if not reqt.proxy and not _M.PROXY then
+ u = {
+ path = socket.try(reqt.path, "invalid path 'nil'"),
+ params = reqt.params,
+@@ -198,7 +198,7 @@ local function adjusturi(reqt)
+ end
+
+ local function adjustproxy(reqt)
+- local proxy = reqt.proxy or PROXY
++ local proxy = reqt.proxy or _M.PROXY
+ if proxy then
+ proxy = url.parse(proxy)
+ return proxy.host, proxy.port or 3128
diff --git a/dev-lua/luasocket/luasocket-3.0_rc1-r4.ebuild b/dev-lua/luasocket/luasocket-3.0_rc1-r4.ebuild
new file mode 100644
index 000000000000..9789a03154f5
--- /dev/null
+++ b/dev-lua/luasocket/luasocket-3.0_rc1-r4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib multilib-minimal flag-o-matic
+
+DESCRIPTION="Networking support library for the Lua language"
+HOMEPAGE="http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/"
+SRC_URI="https://github.com/diegonehab/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/lua-5.1.5-r2[deprecated,${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${PN}-${PV/_/-}
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/proxy-fix.patch
+)
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ LD="$(tc-getCC) ${LDFLAGS}"\
+ $(usex debug DEBUG="DEBUG" "")
+}
+
+multilib_src_install() {
+ local luav=$($(tc-getPKG_CONFIG) --variable V lua)
+ emake \
+ DESTDIR="${D}" \
+ LUAPREFIX_linux=/usr \
+ LUAV=${luav} \
+ CDIR_linux=$(get_libdir)/lua/${luav} \
+ install-unix
+}
+
+multilib_src_install_all() {
+ dodoc NEW README
+ docinto html
+ dodoc -r doc/.
+}