summaryrefslogtreecommitdiff
path: root/dev-lua
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-lua
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/Manifest.gzbin6805 -> 6968 bytes
-rw-r--r--dev-lua/md5/Manifest3
-rw-r--r--dev-lua/md5/md5-1.3.ebuild85
-rw-r--r--dev-lua/md5/metadata.xml17
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-lua/Manifest.gz b/dev-lua/Manifest.gz
index 39ede8459be7..9a6c43db8b7e 100644
--- a/dev-lua/Manifest.gz
+++ b/dev-lua/Manifest.gz
Binary files differ
diff --git a/dev-lua/md5/Manifest b/dev-lua/md5/Manifest
new file mode 100644
index 000000000000..eb6fd34d8f92
--- /dev/null
+++ b/dev-lua/md5/Manifest
@@ -0,0 +1,3 @@
+DIST md5-1.3.tar.gz 31377 BLAKE2B b6080c1ef71b5dd1e2d1831b055f31c6a45dd530a24436440a2188500f2fe0ad45730b23627eed7135b01102797a290af65b7550960add10346ac9f7ce906a9a SHA512 eda222b89432228a03c603237a787d55b6d0251f53ee3da11aaf0369ff26e3497ed8479a295b659e02b3fee85c636cd5f8cc9fd68367bf4ed2d3edcbbc373903
+EBUILD md5-1.3.ebuild 1438 BLAKE2B 06b5cd287df65ca1a858cd17a32bca4ff859ea89e6d1a59c07a86de95a4eee3fa8be243d53f47075878f9bb93ac4cb21a949eef0f414a3cd861366757626135f SHA512 012790412b94ea663d68cbee6402e0217f16e0adc02f59520555a9008d48ac43baefdc9c2b91e900dcccfe6645ab092ab2a7680aa63b8e554ac420cdf9968bc8
+MISC metadata.xml 577 BLAKE2B ed6148bb3d21f02d25b407422a27b560b2df95b9ac8559da7fdb4de12043c1ab91c67c58ad68e92c5e1f87bf80f85abc9c06e2ee5bbba4ca30201574d0e8e94e SHA512 9ef7c55f4655d8af6e99456b5f2737d2c3436b584f49a5f565b61bbcda60dd41f92e72ac9eaa39c2bf72fdd77080f544cc250eddd1065363c26f57324548c4d1
diff --git a/dev-lua/md5/md5-1.3.ebuild b/dev-lua/md5/md5-1.3.ebuild
new file mode 100644
index 000000000000..95caf85b7d2f
--- /dev/null
+++ b/dev-lua/md5/md5-1.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua
+
+DESCRIPTION="Offers basic cryptographic facilities for Lua"
+HOMEPAGE="https://github.com/keplerproject/md5"
+SRC_URI="https://github.com/keplerproject/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+src_configure() {
+ # Provided 'configure' script is useless.
+ :;
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "CFLAGS=${CFLAGS} $(lua_get_CFLAGS) ${LDFLAGS}"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}/src" || die
+
+ # Workaround for tests.
+ ln -s core.so md5.so || die
+
+ "${ELUA}" ../tests/test.lua
+
+ popd
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ # Workaround, as 'Makefile' does not create this directory.
+ dodir "$(lua_get_cmod_dir)"
+
+ local myemakeargs=(
+ "LUA_DIR=${ED}/$(lua_get_lmod_dir)"
+ "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}
diff --git a/dev-lua/md5/metadata.xml b/dev-lua/md5/metadata.xml
new file mode 100644
index 000000000000..5907ba34a816
--- /dev/null
+++ b/dev-lua/md5/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ MD5 offers basic cryptographic facilities for Lua.
+ A hash (digest) function, a pair crypt/decrypt based on MD5 and CFB,
+ and a pair crypt/decrypt based on DES with 56-bit keys.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">keplerproject/md5</remote-id>
+ </upstream>
+</pkgmetadata>