summaryrefslogtreecommitdiff
path: root/dev-lua
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 15:20:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 15:20:44 +0000
commit177349fb1459039cc30cb8e3936af4117d038c16 (patch)
tree34c1bc161daefb8e152212dfba02b98da8a777a5 /dev-lua
parentc15acf374d4b25ba5afcb52435da6090f2d98a20 (diff)
gentoo auto-resync : 10:12:2022 - 15:20:44
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/Manifest.gzbin7291 -> 7290 bytes
-rw-r--r--dev-lua/luarocks/Manifest2
-rw-r--r--dev-lua/luarocks/luarocks-3.9.2.ebuild86
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-lua/Manifest.gz b/dev-lua/Manifest.gz
index 2770d6df9673..ba51ca03d245 100644
--- a/dev-lua/Manifest.gz
+++ b/dev-lua/Manifest.gz
Binary files differ
diff --git a/dev-lua/luarocks/Manifest b/dev-lua/luarocks/Manifest
index e4a24d6ffb4e..f146e0dc7795 100644
--- a/dev-lua/luarocks/Manifest
+++ b/dev-lua/luarocks/Manifest
@@ -1,3 +1,5 @@
DIST luarocks-3.9.1.tar.gz 253375 BLAKE2B 6d622e87dc385d0851ef6366e0b6832f1a453d2590c090b06ec6ab81b8a15930c1496bf2ac00ed6b15a44dfbc43b1f235092947389714b72f3442f802236fab3 SHA512 2dfc1326118c2868b05a17acc5fe8d2c07503ef2bb3f2560a3d7ce385b85893d593bacfab7086c57923f042d7e7cfd09a0a9795afc473a73edbba0a44d23ed60
+DIST luarocks-3.9.2.tar.gz 256117 BLAKE2B eebbad38dd71b0318852a177d394df5fd20e807d566893a2338526e76e17daf2436309e512dd50b325914b2d84b90ef857396bfd6d41f22893131ed78931b8ad SHA512 7e93164bdcf35338e993822931a8e59957ab69c6e23236a7a075649c2f7cd173305c4ca6e9d115fc5e282cb76c21754d7adac92b21885006e5ee3bc06a9d0059
EBUILD luarocks-3.9.1.ebuild 2032 BLAKE2B e45bdc7e716298f0834e042a2693a012483fadc1136feb43a7b6cd1dd1aafffcf9c66fd89bd4b9a5862bae63ce33f3dc92700a65f503b9b4e0fadcae4d8ec5d0 SHA512 66cc22c41de85c3c49defe5b0b031a375c1e9eebcee8779a91fb89784e237d4ce0648a7198daa64b2812f74fba7daedb2fcab84413a7005a891176f80c48b4fd
+EBUILD luarocks-3.9.2.ebuild 2036 BLAKE2B 96cd67a94991f1cd72f87fbd3081b2b6045c479c4a13f8f70b648b2dbb6a21d9e11442603f7ab7bd255dfc1a477c70cef0bb057d6ab871e1be8bb049eb648304 SHA512 75069c2eaf57815d9528d851afe4c29b14e64c5f0887d9103c12a6b57b7e8ae63d48f036471bcdb22837712410357d007d389a3339dcdeba1b841573514f7388
MISC metadata.xml 501 BLAKE2B 0a2a3e7358a2ef2a4cbb79853408dfdf6015d49348bbb879a59253a88c73cf3d96c2ce708076844344468136d70962be74e639d24331a007fbd02ce6ccc18cee SHA512 43f147be67209e542e02733b6a57ce7ee05b61a7eb0d15662c0fb137db4f57c9f519cc98cf5dceb0e6f626f0dc6f04dd5b67da96a155b1e3884dca55896722f3
diff --git a/dev-lua/luarocks/luarocks-3.9.2.ebuild b/dev-lua/luarocks/luarocks-3.9.2.ebuild
new file mode 100644
index 000000000000..7928ca87e717
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-3.9.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="A package manager for the Lua programming language"
+HOMEPAGE="https://luarocks.org"
+SRC_URI="https://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/openssl:0
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/busted-htest[${LUA_USEDEP}]')
+ ${RDEPEND}
+ )
+"
+
+src_prepare() {
+ default
+
+ # If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists,
+ # as no compiled modules are installed on a new, fresh installation,
+ # so this check must be disabled, otherwise 'configure' will fail.
+ sed -e '/LUA_LIBDIR is not a valid directory/d' -i configure || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ "--prefix=${EPREFIX}/usr"
+ "--rocks-tree=$(lua_get_lmod_dir)"
+ "--with-lua-include=$(lua_get_include_dir)"
+ "--with-lua-interpreter=${ELUA}"
+ "--with-lua-lib=$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+}
+
+src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_install() {
+ default
+
+ { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die
+}
+
+pkg_postinst() {
+ local lua_abi_ver
+ if use lua_single_target_luajit; then
+ lua_abi_ver="5.1"
+ else
+ lua_abi_ver=${ELUA#lua}
+ fi
+ elog
+ elog "To manage rocks for a Lua version other than the current ${CATEGORY}/${PN} default (${lua_abi_ver})"
+ elog "you can use the command-line option --lua-version, e.g."
+ elog
+ elog " luarocks --lua-version 5.3 install luasocket"
+ elog
+ elog "(use 5.1 for luajit). Note that the relevant Lua version must already be present in the system."
+ elog
+}