summaryrefslogtreecommitdiff
path: root/dev-lua/toluapp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lua/toluapp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lua/toluapp')
-rw-r--r--dev-lua/toluapp/Manifest3
-rw-r--r--dev-lua/toluapp/metadata.xml7
-rw-r--r--dev-lua/toluapp/toluapp-1.0.93.ebuild50
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-lua/toluapp/Manifest b/dev-lua/toluapp/Manifest
new file mode 100644
index 000000000000..1ddb739a4754
--- /dev/null
+++ b/dev-lua/toluapp/Manifest
@@ -0,0 +1,3 @@
+DIST tolua++-1.0.93.tar.bz2 163956 BLAKE2B e4ff54ec130036654446a6e1f5d487d40af9ebbf2fdb3a8ae055fd20768fad6434fdfd4f359369dbc3669565f54dad3d6957da06c6e029e6abe6a529861ff96e SHA512 d1ae56b2dd38437e0aef81d5230d1a954b8f914133cfa199a18193d05ecfd188ec2bbeec76e63846ef673dc89c12e47bfd9727c227b71833d622cc441c071013
+EBUILD toluapp-1.0.93.ebuild 1090 BLAKE2B 0d63d5898ff64f87f639ca7cda694858d18849577c53cb126487da3b9365dc8e30b821e3a710c0e299c18ce7397cd139f5476e27d4606a533f7b56064c3a5a96 SHA512 c1ce00a29c5ca0217a423167de7c9f35a1070d6ba008bc0bae6268e3d34b1480dab561d0253c4817b6350b16a6ce213db3126db615d373748e31871baba4128d
+MISC metadata.xml 228 BLAKE2B 6647e8693ddcece1ed5d215bc3502e0a16df0f2fedbf03c0dedac5b669bf0ca178284c69eae29b933f94ec58543c951e7d207d0d8a774fc7e4bfd64f3371ae74 SHA512 27499f64eb2cb593e91dd72dc5498d5df3ea7c4402e86897f79ef6fc7f040c6c09be497959af35ee54943f36ac228a6b92302b5d85763e4d0e96398670e81f45
diff --git a/dev-lua/toluapp/metadata.xml b/dev-lua/toluapp/metadata.xml
new file mode 100644
index 000000000000..379d1734e2d3
--- /dev/null
+++ b/dev-lua/toluapp/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-lua/toluapp/toluapp-1.0.93.ebuild b/dev-lua/toluapp/toluapp-1.0.93.ebuild
new file mode 100644
index 000000000000..408e6ace008f
--- /dev/null
+++ b/dev-lua/toluapp/toluapp-1.0.93.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+MY_P=${P/pp/++}
+
+DESCRIPTION="A tool to integrate C/C++ code with Lua"
+HOMEPAGE="http://www.codenix.com/~tolua/"
+SRC_URI="http://www.codenix.com/~tolua/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1.1[deprecated]"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ echo "## BEGIN gentoo.py
+
+LIBS = ['lua', 'dl', 'm']
+
+## END gentoo.py" > ${S}/custom.py
+
+ scons \
+ CC="$(tc-getCC)" \
+ CCFLAGS="${CFLAGS} -ansi -Wall" \
+ CXX="$(tc-getCXX)" \
+ LINK="$(tc-getCC)" \
+ LINKFLAGS="${LDFLAGS}" \
+ shared=1 || die "scons failed"
+}
+
+src_install() {
+ dobin bin/tolua++ || die "dobin failed"
+# dobin bin/tolua++_bootstrap || die "dobin failed"
+# dolib.a lib/libtolua++_static.a || die "dolib.a failed"
+ dolib.so lib/libtolua++.so || die "dolib.so failed"
+ insinto /usr/include
+ doins include/tolua++.h || die "doins failed"
+ dodoc README
+ dohtml doc/*
+}