summaryrefslogtreecommitdiff
path: root/dev-lua/say/say-1.3_p1-r101.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /dev-lua/say/say-1.3_p1-r101.ebuild
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'dev-lua/say/say-1.3_p1-r101.ebuild')
-rw-r--r--dev-lua/say/say-1.3_p1-r101.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lua/say/say-1.3_p1-r101.ebuild b/dev-lua/say/say-1.3_p1-r101.ebuild
new file mode 100644
index 000000000000..cef73fc92c85
--- /dev/null
+++ b/dev-lua/say/say-1.3_p1-r101.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lua String Hashing/Indexing Library"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( >=dev-lua/busted-2.0.0-r100[${LUA_USEDEP}] )
+ ${RDEPEND}
+"
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)/say
+ doins src/init.lua
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}