summaryrefslogtreecommitdiff
path: root/dev-lua/luv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-lua/luv
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-lua/luv')
-rw-r--r--dev-lua/luv/Manifest2
-rw-r--r--dev-lua/luv/luv-1.36.0.0.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-lua/luv/Manifest b/dev-lua/luv/Manifest
index bb785f9e31fc..40987bb4c52b 100644
--- a/dev-lua/luv/Manifest
+++ b/dev-lua/luv/Manifest
@@ -1,5 +1,7 @@
AUX luv-1.32.0.0-cmake_lua_version.patch 342 BLAKE2B f4b6b5d45ed4b39ba0a1ed0ae60708583be04cb9a2e785c1ba09a171c7cdeb3cb18e1baf9dba976c429d6f7a5737c0c8ca803b3241d170f395f6045da03ece03 SHA512 6e8341db5eeb5c1e51cc9c812ffc99c2a15a18467456fa20c7dc37c100ac269ef4b416a311f7d435b89c824171218193b00e8e7dccf7506eaf789a88121866bd
DIST luv-1.32.0.0.tar.gz 91349 BLAKE2B e4a90b3241e2fe650f62e34439ed75f9ba53168d6bd96b8685fc5600d6f9cbb1bb598a7d40d918ab9123cf4bad99f872a79d0664056d35caba52d1eda9046020 SHA512 7db52afc1ca79052e349be7a37deb67066ee9005f8d7f7d0dae62bd83a93b4140103ee6dddeca2e02a3fc37b3880a5c18904429886af1d441f8de0cfabf5bd8c
+DIST luv-1.36.0.0.tar.gz 107196 BLAKE2B 31a02c3e928559037355186810187299a3cb1420265a27756b0613781621c78c18edc272072cc29c46336787b040453cc9a06195264c0a72a985e49c48202022 SHA512 3119c1450a8317725d59cc1ab6afccfbde752b0c32b38909dfdd31bf88ea0751920dc68750da52cf17a6430637cf1094f4d5500e4c50d1145eca48bb12728ba1
DIST luv-lua-compat-0.10.tar.gz 53695 BLAKE2B e570aedb23b8ed7ca38c4316ffab25b93a0f9f6f0fae79af563ca8a81dd6453ac273e1f9e70674c484a2dec68749e7d53a1c1736a72616c210b8e38a31b3f191 SHA512 f7f39085f4f6b16095f41e635b4c5477b3dab5e42b5b65a9d522941a3807ea521d4a27a77293a3c9d0ecea78a1f6c2a2497394b2d220f4d7d65e23510563d46d
EBUILD luv-1.32.0.0-r102.ebuild 2183 BLAKE2B 76d88767f5494c469557da85f09e5ba0cec37b529f88c4b8300d8b80d69ad9486547cb7a72bf117be2e7a679c17af22caa6033cad2c344e0636a72f845851ebc SHA512 b0437489b69efee65f690f2dbcd266188ff34736c2a196e51bfb57ff10a10c94f42383151d1ad7cea751e4a7b4ffa0d0676a63710926d7ba1993522fb8e48de8
+EBUILD luv-1.36.0.0.ebuild 2296 BLAKE2B db184e750df7311e87258da93f473d9f1449093b399620da8d6b13824f6b3e067bb1cfff9531f84af9f77e032711aba6e3fd37afee6174ce0c5aad63dc943047 SHA512 3b3122bc5421ab16a09c465f7a37bdd43f80424cadaf66f8fb471349ee4c4bcceadba3c48957717e0ad599d4d3054aa00c21d031164104ee996464c26e2f8f88
MISC metadata.xml 478 BLAKE2B 922ac075f7e73e4e72b831c95ae3341a37d107111f05bd685e6a10d6ef93fa332a7bd1078e559c31b8a0686c86edca7d3dd015f1cadb50fad4eaabc311ff8e55 SHA512 80486058a108d2a2568652c49e26b067f5ab7908cf0edf6ae0073a7e139e47b5821e9b959e01ab7a4be82d2614291d4fe16cac29778c88090690494760d85430
diff --git a/dev-lua/luv/luv-1.36.0.0.ebuild b/dev-lua/luv/luv-1.36.0.0.ebuild
new file mode 100644
index 000000000000..74f839486381
--- /dev/null
+++ b/dev-lua/luv/luv-1.36.0.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit cmake flag-o-matic lua-single unpacker
+
+# e.g. MY_PV = a.b.c-d
+MY_PV="$(ver_rs 3 -)"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Bare libuv bindings for lua"
+HOMEPAGE="https://github.com/luvit/luv"
+
+LUA_COMPAT_PV="0.10"
+SRC_URI="
+ https://github.com/luvit/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/keplerproject/lua-compat-5.3/archive/v${LUA_COMPAT_PV}.tar.gz -> ${PN}-lua-compat-${LUA_COMPAT_PV}.tar.gz
+"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="${LUA_DEPS}
+ >=dev-libs/libuv-1.32.0:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.32.0.0-cmake_lua_version.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix libdir
+ # Match '/lib/' and '/lib"' without capturing / or ", replacing with libdir
+ sed -i -r "s/\/lib(\"|\/)/\/$(get_libdir)\1/g" CMakeLists.txt || die "Failed to sed CMakeLists.txt"
+ cmake_src_prepare
+}
+
+# This could in theory be multi-impl (and we have an ebuild in git history,
+# 1.32.0.0-r101, which implements it) - the only revdep currently in the tree,
+# app-editors/neovim, actually links against luv instead of trying to load it
+# as a module. We could probably implement some sort of a hack for this
+# - but given how messy it would be, don't bother unless someone actually requests
+# luv multi-impl support.
+src_configure() {
+ lua_compat_dir="${WORKDIR}/lua-compat-5.3-${LUA_COMPAT_PV}"
+
+ local mycmakeargs=(
+ -DBUILD_MODULE=OFF
+ -DLUA_BUILD_TYPE=System
+ -DLUA_COMPAT53_DIR="${lua_compat_dir}"
+ -DWITH_SHARED_LIBUV=ON
+ )
+ if [[ ${ELUA} == luajit ]]; then
+ mycmakeargs+=(
+ -DWITH_LUA_ENGINE=LuaJIT
+ )
+ else
+ mycmakeargs+=(
+ -DWITH_LUA_ENGINE=Lua
+ -DLUA_VERSION=$(ver_cut 1-2 $(lua_get_version))
+ )
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ append-ldflags "-undefined dynamic_lookup"
+ fi
+
+ cmake_src_configure
+}
+
+src_test() {
+ # We need to copy the library back so that the tests see it
+ ln -s "${BUILD_DIR}/libluv.so" "./luv.so" || die "Failed to symlink library for tests"
+ ${ELUA} "tests/run.lua" || die "Tests failed"
+}