summaryrefslogtreecommitdiff
path: root/dev-lua/luarocks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-lua/luarocks
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-lua/luarocks')
-rw-r--r--dev-lua/luarocks/Manifest2
-rw-r--r--dev-lua/luarocks/luarocks-3.9.0.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-lua/luarocks/Manifest b/dev-lua/luarocks/Manifest
index 37c7b4864adb..8001e428b0d9 100644
--- a/dev-lua/luarocks/Manifest
+++ b/dev-lua/luarocks/Manifest
@@ -1,3 +1,5 @@
DIST luarocks-3.8.0.tar.gz 249787 BLAKE2B 2bfff5af400abfdf17a0eacd1f29838dd77751f2ba085d6c6fc18dfc971ea796523781ff2488566d42c01d005bd5037171bf1aabbfdd664746c55674e3ca32c7 SHA512 6c30884c60da57706228a9870f510a1bce435b2d5d67c63c5f2958b152c7a2b334bd74a016995871e3b05b98374f4c4e008993ede81f9fc564980e183bdf06b2
+DIST luarocks-3.9.0.tar.gz 252777 BLAKE2B fba01692057ea5f4a926db4b31d4a299238079af1dfd15078cbff6d3d17d1b87f9f30db8477b1b706ec4602fe9ef82533ad3cc58f8059fe84490b464da0b3c15 SHA512 ccdee2ff14f52428923d5148f3d86d2ad40f84685988a12419c191c73a4df6cfacb0defbea40556493645619fdbef807e198fbae85be69c4075b5212353c1f2d
EBUILD luarocks-3.8.0.ebuild 2032 BLAKE2B c35eac393ab58c03ec8b8571f77728cc24b9a8e6b46f9863e93ec2c90ce10db271bb168a41f712801a5598e49ce5226013497768e495b77ba2d3ec0b2c45459b SHA512 a61f31bd7262e9d9f6af0b126a3e4fe41e805a54f4a7765b770a1a1bb4f2b1ab748fc1cdfb3482fb5097c1eec2f8918a889257246e27dde39cebe13257cfc3d4
+EBUILD luarocks-3.9.0.ebuild 2036 BLAKE2B 96cd67a94991f1cd72f87fbd3081b2b6045c479c4a13f8f70b648b2dbb6a21d9e11442603f7ab7bd255dfc1a477c70cef0bb057d6ab871e1be8bb049eb648304 SHA512 75069c2eaf57815d9528d851afe4c29b14e64c5f0887d9103c12a6b57b7e8ae63d48f036471bcdb22837712410357d007d389a3339dcdeba1b841573514f7388
MISC metadata.xml 501 BLAKE2B 0a2a3e7358a2ef2a4cbb79853408dfdf6015d49348bbb879a59253a88c73cf3d96c2ce708076844344468136d70962be74e639d24331a007fbd02ce6ccc18cee SHA512 43f147be67209e542e02733b6a57ce7ee05b61a7eb0d15662c0fb137db4f57c9f519cc98cf5dceb0e6f626f0dc6f04dd5b67da96a155b1e3884dca55896722f3
diff --git a/dev-lua/luarocks/luarocks-3.9.0.ebuild b/dev-lua/luarocks/luarocks-3.9.0.ebuild
new file mode 100644
index 000000000000..7928ca87e717
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-3.9.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="A package manager for the Lua programming language"
+HOMEPAGE="https://luarocks.org"
+SRC_URI="https://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/openssl:0
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/busted-htest[${LUA_USEDEP}]')
+ ${RDEPEND}
+ )
+"
+
+src_prepare() {
+ default
+
+ # If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists,
+ # as no compiled modules are installed on a new, fresh installation,
+ # so this check must be disabled, otherwise 'configure' will fail.
+ sed -e '/LUA_LIBDIR is not a valid directory/d' -i configure || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ "--prefix=${EPREFIX}/usr"
+ "--rocks-tree=$(lua_get_lmod_dir)"
+ "--with-lua-include=$(lua_get_include_dir)"
+ "--with-lua-interpreter=${ELUA}"
+ "--with-lua-lib=$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+}
+
+src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_install() {
+ default
+
+ { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die
+}
+
+pkg_postinst() {
+ local lua_abi_ver
+ if use lua_single_target_luajit; then
+ lua_abi_ver="5.1"
+ else
+ lua_abi_ver=${ELUA#lua}
+ fi
+ elog
+ elog "To manage rocks for a Lua version other than the current ${CATEGORY}/${PN} default (${lua_abi_ver})"
+ elog "you can use the command-line option --lua-version, e.g."
+ elog
+ elog " luarocks --lua-version 5.3 install luasocket"
+ elog
+ elog "(use 5.1 for luajit). Note that the relevant Lua version must already be present in the system."
+ elog
+}