summaryrefslogtreecommitdiff
path: root/dev-lua/luaposix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-lua/luaposix
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-lua/luaposix')
-rw-r--r--dev-lua/luaposix/Manifest2
-rw-r--r--dev-lua/luaposix/luaposix-35.0-r101.ebuild (renamed from dev-lua/luaposix/luaposix-35.0-r100.ebuild)18
2 files changed, 13 insertions, 7 deletions
diff --git a/dev-lua/luaposix/Manifest b/dev-lua/luaposix/Manifest
index 1c378808217b..7af9d95253d2 100644
--- a/dev-lua/luaposix/Manifest
+++ b/dev-lua/luaposix/Manifest
@@ -1,4 +1,4 @@
DIST luaposix-35.0.tar.gz 178091 BLAKE2B b2d2ca01f18f0e98b45008919fc886e05d2cad034c84e870900c33891dd5867d9bc7aa8deae06c3f3f0852db902c1e766e693162b32ed474eb710b379bf9e3ed SHA512 4bb61892b78d9e59418a9a6360b9f611fb9b5438b9261a2c6672f053a1b21dfd9a2060b8d2f0d3eac6185773cf84672c1769c081c4ab53d2ddae2232e4a9269b
-EBUILD luaposix-35.0-r100.ebuild 1598 BLAKE2B ec756a70b9ca70aa714d492104139a7d1bb00f2473dda0db2d97ba1d6337f12f4f5843d3325a66c17957026e58841f4019b006e8d21e8d7f71ce81cce2d71503 SHA512 3ae67e8ebbc85787b301380c169a1c80b33cc9783ce3b640166e05e1c62d7e24233042f09b8c9cb3e63a19f814c832071789170a2302a552afce2b074ea9876f
+EBUILD luaposix-35.0-r101.ebuild 1732 BLAKE2B 4b1e5602401ad2322ea394813f2ca4e6e271d7d941b2564e81f873493b2d8781571d1f1e4f1be7b3243e51f160b88bc85e6cc02f17a710239aa4c18c7d11f0f1 SHA512 8c5b28c3ecdc79777dea414cf0707e79af558221e8b61c2c50bd5461c6a7c534780cd822c2781b1be67cd9cf19b3ea05150e1954128ced63262c95b7223a7d78
EBUILD luaposix-35.0.ebuild 1266 BLAKE2B 49d1d6db7709ae309d926c96ddbd75b2e60aa49005c256dacb57813399e81bbe3350694f308b62b097d723c5f696c1093ab28984e9ea16c50c7eded815a1d2d3 SHA512 a8048912aab2aac73f0f21e56c7fc3a6a05af3d97dc14472ffd92ce50c94d78d80ca87ddd3fed41b4c4bf54d1908c767155c84750d018f1e660c3f5f522a1b21
MISC metadata.xml 474 BLAKE2B c2297ba4eae7fdfaf22dd9f93fe1f41a48ed085a3493fd30dc23e186bc89c5b6f0dc535fad0e15af24f8d9498c38ee8e99f7fafae0ac2969d91cca96fefe4ba6 SHA512 b0acb936e00d9668b5cad5478243d3067677ee015451cc06d0a7165a0e87035d23347f8dd40f481088be178d0ca6d06486b8984910021171903a37be970519e4
diff --git a/dev-lua/luaposix/luaposix-35.0-r100.ebuild b/dev-lua/luaposix/luaposix-35.0-r101.ebuild
index 7881ac5e4801..3e7b5157e6ee 100644
--- a/dev-lua/luaposix/luaposix-35.0-r100.ebuild
+++ b/dev-lua/luaposix/luaposix-35.0-r101.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,6 +14,7 @@ SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
REQUIRED_USE="${LUA_REQUIRED_USE}"
# Requires specl, which is not in the tree yet
@@ -22,7 +23,8 @@ RESTRICT="test"
DEPEND="${LUA_DEPS}"
RDEPEND="${DEPEND}
lua_targets_lua5-1? ( dev-lua/lua-bit32[lua_targets_lua5-1(-)] )
- lua_targets_luajit? ( dev-lua/lua-bit32[lua_targets_luajit(-)] )"
+ lua_targets_luajit? ( dev-lua/lua-bit32[lua_targets_luajit(-)] )
+"
BDEPEND="virtual/pkgconfig"
src_prepare() {
@@ -39,13 +41,15 @@ src_prepare() {
lua_src_compile() {
pushd "${BUILD_DIR}" || die
- ./build-aux/luke package="${PN}" version="${PV}" \
+ # LDOC=true means disable ldoc update documentation
+ ./build-aux/luke --verbose package="${PN}" version="${PV}" \
+ LDOC=true \
PREFIX="${ED}/usr" \
INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" || die
- popd
+ popd || die
}
src_compile() {
@@ -56,15 +60,17 @@ lua_src_install() {
pushd "${BUILD_DIR}" || die
./build-aux/luke install \
+ LDOC=true \
PREFIX="${ED}/usr" \
INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
|| die
- popd
+ popd || die
}
src_install() {
lua_foreach_impl lua_src_install
- dodoc -r doc NEWS.md README.md
+ dodoc {NEWS,README}.md
+ use doc && dodoc -r doc
}