summaryrefslogtreecommitdiff
path: root/dev-lua/luaposix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-lua/luaposix
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-lua/luaposix')
-rw-r--r--dev-lua/luaposix/Manifest3
-rw-r--r--dev-lua/luaposix/luaposix-35.0-r100.ebuild70
-rw-r--r--dev-lua/luaposix/luaposix-35.0.ebuild4
3 files changed, 74 insertions, 3 deletions
diff --git a/dev-lua/luaposix/Manifest b/dev-lua/luaposix/Manifest
index 8dcb9c3c0164..1c378808217b 100644
--- a/dev-lua/luaposix/Manifest
+++ b/dev-lua/luaposix/Manifest
@@ -1,3 +1,4 @@
DIST luaposix-35.0.tar.gz 178091 BLAKE2B b2d2ca01f18f0e98b45008919fc886e05d2cad034c84e870900c33891dd5867d9bc7aa8deae06c3f3f0852db902c1e766e693162b32ed474eb710b379bf9e3ed SHA512 4bb61892b78d9e59418a9a6360b9f611fb9b5438b9261a2c6672f053a1b21dfd9a2060b8d2f0d3eac6185773cf84672c1769c081c4ab53d2ddae2232e4a9269b
-EBUILD luaposix-35.0.ebuild 1267 BLAKE2B 12cefcfb60eb5bdc13a789587fe8d8911c8ba59f89c80ce0959f98c7a0896c183f1a39bcb7e4f14a57e11240460fcf7804da1f82d8d2ece70123fa447174c7fd SHA512 85649949f8bd79602e1d79ac17e654c2f47d7246725d7763286da0dc538e50d3fc00e9c38995c59d4a9c9952576635979f83babe4e1ed53895036380cdb81ae5
+EBUILD luaposix-35.0-r100.ebuild 1598 BLAKE2B ec756a70b9ca70aa714d492104139a7d1bb00f2473dda0db2d97ba1d6337f12f4f5843d3325a66c17957026e58841f4019b006e8d21e8d7f71ce81cce2d71503 SHA512 3ae67e8ebbc85787b301380c169a1c80b33cc9783ce3b640166e05e1c62d7e24233042f09b8c9cb3e63a19f814c832071789170a2302a552afce2b074ea9876f
+EBUILD luaposix-35.0.ebuild 1266 BLAKE2B 49d1d6db7709ae309d926c96ddbd75b2e60aa49005c256dacb57813399e81bbe3350694f308b62b097d723c5f696c1093ab28984e9ea16c50c7eded815a1d2d3 SHA512 a8048912aab2aac73f0f21e56c7fc3a6a05af3d97dc14472ffd92ce50c94d78d80ca87ddd3fed41b4c4bf54d1908c767155c84750d018f1e660c3f5f522a1b21
MISC metadata.xml 474 BLAKE2B c2297ba4eae7fdfaf22dd9f93fe1f41a48ed085a3493fd30dc23e186bc89c5b6f0dc535fad0e15af24f8d9498c38ee8e99f7fafae0ac2969d91cca96fefe4ba6 SHA512 b0acb936e00d9668b5cad5478243d3067677ee015451cc06d0a7165a0e87035d23347f8dd40f481088be178d0ca6d06486b8984910021171903a37be970519e4
diff --git a/dev-lua/luaposix/luaposix-35.0-r100.ebuild b/dev-lua/luaposix/luaposix-35.0-r100.ebuild
new file mode 100644
index 000000000000..7881ac5e4801
--- /dev/null
+++ b/dev-lua/luaposix/luaposix-35.0-r100.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Bindings for POSIX APIs"
+HOMEPAGE="https://luaposix.github.io/luaposix/ https://github.com/luaposix/luaposix"
+SRC_URI="https://github.com/luaposix/luaposix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Requires specl, which is not in the tree yet
+RESTRICT="test"
+
+DEPEND="${LUA_DEPS}"
+RDEPEND="${DEPEND}
+ lua_targets_lua5-1? ( dev-lua/lua-bit32[lua_targets_lua5-1(-)] )
+ lua_targets_luajit? ( dev-lua/lua-bit32[lua_targets_luajit(-)] )"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Temporary fix for respect LDFLAGS (#739050)
+ # Fixed in luke 0.2.1
+ sed -i -e "s:c_module,libdirs:c_module,'\$LDFLAGS',libdirs:g" \
+ build-aux/luke || die
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ ./build-aux/luke package="${PN}" version="${PV}" \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
+ INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" || die
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ ./build-aux/luke install \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
+ INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
+ || die
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+ dodoc -r doc NEWS.md README.md
+}
diff --git a/dev-lua/luaposix/luaposix-35.0.ebuild b/dev-lua/luaposix/luaposix-35.0.ebuild
index 06ef159c1e90..efcbfd7161c0 100644
--- a/dev-lua/luaposix/luaposix-35.0.ebuild
+++ b/dev-lua/luaposix/luaposix-35.0.ebuild
@@ -12,9 +12,9 @@ SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-RDEPEND="dev-lang/lua:0=
+DEPEND="dev-lang/lua:0="
+RDEPEND="${DEPEND}
dev-lua/lua-bit32"
-DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_prepare() {