summaryrefslogtreecommitdiff
path: root/dev-lua/luaposix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-lua/luaposix
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-lua/luaposix')
-rw-r--r--dev-lua/luaposix/Manifest2
-rw-r--r--dev-lua/luaposix/luaposix-35.1.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-lua/luaposix/Manifest b/dev-lua/luaposix/Manifest
index 7e2e7bb952f8..4455170acc9d 100644
--- a/dev-lua/luaposix/Manifest
+++ b/dev-lua/luaposix/Manifest
@@ -1,3 +1,5 @@
DIST luaposix-35.0.tar.gz 178091 BLAKE2B b2d2ca01f18f0e98b45008919fc886e05d2cad034c84e870900c33891dd5867d9bc7aa8deae06c3f3f0852db902c1e766e693162b32ed474eb710b379bf9e3ed SHA512 4bb61892b78d9e59418a9a6360b9f611fb9b5438b9261a2c6672f053a1b21dfd9a2060b8d2f0d3eac6185773cf84672c1769c081c4ab53d2ddae2232e4a9269b
+DIST luaposix-35.1.tar.gz 180002 BLAKE2B fc48ae91c31968cb92ea9818148f135e16e2bacac10265cbfa43539c34a934c4eb636417b820ce3b0b3724fecbf27a860c6b481749d339b009fc01b6f81e6277 SHA512 f2c36bf69c0d73b4a2c6ab0915f81473addce427c22e82e2d1c334016dec7fecb4365fc980fa6adb0de21ad1a60bc75b73f58579e8a423990ad2067c9ae37775
EBUILD luaposix-35.0-r103.ebuild 1835 BLAKE2B 6223069db43b82d34ae389954d528d8212122fcef2200319c39a2b0fcc89f4120768bb1cdb2bfe95c734649dd9b0469e87d8d5f7dc97a4a53b8ecba8a51a8ff8 SHA512 a1b1a134363de4fe57a583493dd7196594d4fc1d0919ac2dbc1e083c08b7661637ffe94e9a0ad4ceeb96a0accb78ffb7e6b181a41ac55cf1d44c0d0b634fc90f
+EBUILD luaposix-35.1.ebuild 1674 BLAKE2B 62ba3a833e56f4aa46db67a59407e8335548b7accc1b5197255192102ff225d3f134bde0e047d63d56ceeb288db2429e592dca09e554a95899e3c0fb2f639feb SHA512 afb4495a078d36b24e2a83123aa0201f479099918b07c1b64749442546bcb0d1f02a29dc568e243de08fc3823c0465d1668e0e56d3dbd0c1c562d2855be646d1
MISC metadata.xml 505 BLAKE2B 42b52401c50e93a3698230d49e18e22f600de6e1b991a8294d3c7dad3eeaea7f88029f60db28d6b29b4fb825e75627647e1c5d771b0bf3030e99676fb40110bb SHA512 fa4fe245d0dd8497bfbb0fd13568401258085fc7d3a2f31167a7ba816f2b979430d76bdaccb5fcb5ed7840d559a3478f7208a972cf665a426a9336cd74059654
diff --git a/dev-lua/luaposix/luaposix-35.1.ebuild b/dev-lua/luaposix/luaposix-35.1.ebuild
new file mode 100644
index 000000000000..656a22c8df1d
--- /dev/null
+++ b/dev-lua/luaposix/luaposix-35.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Bindings for POSIX APIs"
+HOMEPAGE="https://luaposix.github.io/luaposix/ https://github.com/luaposix/luaposix"
+SRC_URI="https://github.com/luaposix/luaposix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Requires specl, which is not in the tree yet
+RESTRICT="test"
+
+DEPEND="${LUA_DEPS}
+ virtual/libcrypt:=
+"
+RDEPEND="${DEPEND}
+ lua_targets_lua5-1? ( dev-lua/lua-bit32[lua_targets_lua5-1(-)] )
+ lua_targets_luajit? ( dev-lua/lua-bit32[lua_targets_luajit(-)] )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ # LDOC=true means disable ldoc update documentation
+ ./build-aux/luke --verbose package="${PN}" version="${PV}" \
+ LDOC=true \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
+ INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
+ LUA_INCDIR="${EPREFIX}/$(lua_get_include_dir)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" || die
+
+ popd || die
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ ./build-aux/luke install \
+ LDOC=true \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
+ INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
+ || die
+
+ popd || die
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+ dodoc {NEWS,README}.md
+ use doc && dodoc -r doc
+}