summaryrefslogtreecommitdiff
path: root/dev-lua/lualdap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-lua/lualdap
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-lua/lualdap')
-rw-r--r--dev-lua/lualdap/Manifest3
-rw-r--r--dev-lua/lualdap/lualdap-1.2.5.ebuild (renamed from dev-lua/lualdap/lualdap-1.2.5-r100.ebuild)15
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-lua/lualdap/Manifest b/dev-lua/lualdap/Manifest
index 974d59fe44e1..5fdba5f4eec5 100644
--- a/dev-lua/lualdap/Manifest
+++ b/dev-lua/lualdap/Manifest
@@ -1,3 +1,4 @@
+DIST lua-compat-5.3-0.10.tar.gz 53695 BLAKE2B e570aedb23b8ed7ca38c4316ffab25b93a0f9f6f0fae79af563ca8a81dd6453ac273e1f9e70674c484a2dec68749e7d53a1c1736a72616c210b8e38a31b3f191 SHA512 f7f39085f4f6b16095f41e635b4c5477b3dab5e42b5b65a9d522941a3807ea521d4a27a77293a3c9d0ecea78a1f6c2a2497394b2d220f4d7d65e23510563d46d
DIST lualdap-1.2.5.tar.gz 85920 BLAKE2B 14015fe258fa391e08fc9b6bdb7a71dae10fbd84636cc3d84c446d67f9d0ea925c0086343a29ce21b81f77c87da37040560c631cdf3df7c8d3c255e5913fd985 SHA512 4fbd7bcea2e55a3b165a7316e4f6c45aee22506915c4cc204d1b5006adbf95611ebf4558c1ef1511f90d7142571cff37ea24952072dc7ecb13bbbe06aef32e72
-EBUILD lualdap-1.2.5-r100.ebuild 1445 BLAKE2B 83928ee3e5d1f7fb97ac5687c8d01a4c22eb8422d9de089492dc8b217a009e6610d8c1104f90d98f1718e75bcdcc3b4e8d9ae52c90652710606051c0c8c93994 SHA512 3b4b758d7a9b1bb436b2bdb59de6f8f7804217b14edefe9575ad77610cf729e8ef0b07f2cb5ac7987a88b00e2dea35eae90dc8b2ea5445c463a98d524e13d148
+EBUILD lualdap-1.2.5.ebuild 1775 BLAKE2B bdaa9788774d711fa28952705ef4b87d0d79bbecb206b58364147e0cdf0879800568108c920685d23fee37939618a8d08ce5c6f1ba14d3939ebc9711619b3a38 SHA512 96944fae16d8858c043096bd7aea66843f6c89d2c8498339454ff9858622bf33075838e6077f3977b3e361f6f9dae479f989a740a19ae3492d42918d681a5ff2
MISC metadata.xml 547 BLAKE2B eac91a6aa0723c8442142daad10af992c7142bafbe29f9ec748418b49eac2dc4bbd034ae4994026238eb8f7339f9d86e7c823f3c33a54a4fbde13e8f2fe8ddff SHA512 d893b983ca2b1bba4de32a90f9b0df79fdb30ee937d978ae506b2c07c7ae6d9d0d8c4e9ecbf09f6e2b4d54e95bef8482035b63672a41119e30d74244674c3f10
diff --git a/dev-lua/lualdap/lualdap-1.2.5-r100.ebuild b/dev-lua/lualdap/lualdap-1.2.5.ebuild
index af582b86b150..d8210cb3aa77 100644
--- a/dev-lua/lualdap/lualdap-1.2.5-r100.ebuild
+++ b/dev-lua/lualdap/lualdap-1.2.5.ebuild
@@ -1,15 +1,21 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-LUA_COMPAT=( lua5-{1..3} luajit )
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PN_LUACOMPAT="lua-compat-5.3"
+MY_PV_LUACOMPAT="0.10"
+MY_P_LUACOMPAT="${MY_PN_LUACOMPAT}-${MY_PV_LUACOMPAT}"
inherit lua toolchain-funcs
DESCRIPTION="A lua binding for the OpenLDAP client libraries"
HOMEPAGE="https://github.com/lualdap/lualdap"
-SRC_URI="https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="
+ https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/keplerproject/${MY_PN_LUACOMPAT}/archive/v${MY_PV_LUACOMPAT}.tar.gz -> ${MY_P_LUACOMPAT}.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -33,6 +39,9 @@ HTML_DOCS=( "doc/us/." )
src_prepare() {
default
+ # Copy current lua-compat-5.3 files to support lua5-4
+ cp ../${MY_P_LUACOMPAT}/c-api/* src || die
+
lua_copy_sources
}