summaryrefslogtreecommitdiff
path: root/dev-lua/luajson/luajson-1.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lua/luajson/luajson-1.3.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lua/luajson/luajson-1.3.3.ebuild')
-rw-r--r--dev-lua/luajson/luajson-1.3.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lua/luajson/luajson-1.3.3.ebuild b/dev-lua/luajson/luajson-1.3.3.ebuild
new file mode 100644
index 000000000000..f38c914fbd8a
--- /dev/null
+++ b/dev-lua/luajson/luajson-1.3.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="JSON Parser/Constructor for Lua"
+HOMEPAGE="https://www.eharning.us/wiki/luajson/"
+SRC_URI="https://github.com/harningt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ppc ppc64 sparc ~x86"
+IUSE="test"
+
+RDEPEND="|| ( >=dev-lang/lua-5.1 dev-lang/luajit:2 )
+ dev-lua/lpeg"
+DEPEND="test? ( dev-lua/luafilesystem )"
+
+# lunit not in the tree yet
+RESTRICT="test"
+
+# nothing to compile
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+ dodoc README docs/ReleaseNotes-${PV}.txt docs/LuaJSON.txt
+}