summaryrefslogtreecommitdiff
path: root/dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild')
-rw-r--r--dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild b/dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild
new file mode 100644
index 000000000000..9995175daabd
--- /dev/null
+++ b/dev-lua/luafilesystem/luafilesystem-1.6.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+DESCRIPTION="File System Library for the Lua Programming Language"
+HOMEPAGE="https://keplerproject.github.com/luafilesystem/"
+SRC_URI="mirror://github/keplerproject/luafilesystem/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/lua-5.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s|gcc|$(tc-getCC)|" \
+ -e "s|/usr/local|/usr|" \
+ -e "s|/lib|/$(get_libdir)|" \
+ -e "s|-O2|${CFLAGS}|" \
+ -e "/^LIB_OPTION/s|= |= ${LDFLAGS} |" \
+ config || die
+}
+
+src_install() {
+ emake PREFIX="${ED}usr" install
+ dodoc README
+ dohtml doc/us/*
+}