summaryrefslogtreecommitdiff
path: root/dev-lua/lua_cliargs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lua/lua_cliargs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lua/lua_cliargs')
-rw-r--r--dev-lua/lua_cliargs/Manifest5
-rw-r--r--dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild36
-rw-r--r--dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild36
-rw-r--r--dev-lua/lua_cliargs/metadata.xml17
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-lua/lua_cliargs/Manifest b/dev-lua/lua_cliargs/Manifest
new file mode 100644
index 000000000000..8db25cb69293
--- /dev/null
+++ b/dev-lua/lua_cliargs/Manifest
@@ -0,0 +1,5 @@
+DIST lua_cliargs-2.5_p5.tar.gz 19513 BLAKE2B 25cdfd9e96fd0cf5d600394c47ec53dd80e619dac8a37a40e22366e1090ffc9f9f250d71683140959fbd33b3983a759c931c3ac70a3f14e9556005fe5f82f72c SHA512 7c4d490f5d86b07bdf299c976b99bf83c9ba86fabeb321f348587f8ad207983292e3e9268ef72f3cc6ff9d6e32a43669de1d3c21c47499852f971c2cc2a4e746
+DIST lua_cliargs-3.0_p1.tar.gz 29904 BLAKE2B 4cb3e33c0d1331cb9c6cef9b8db67c12cfd3678277e11b6218d56ae38e4678dd48472d65dd959b59bb44d5c42c1e64697fe4e54b67e80933ab706d9d2b01c79f SHA512 2bdcd3c790a82351df598cb3d289de980fe771222ebd9715036678eecdbe51b7563d24629afa4d286b900d722bf844004d12f2330744a1e644d9286ac44b4dbe
+EBUILD lua_cliargs-2.5_p5.ebuild 876 BLAKE2B ba627334a770918356cd474f97b7b8f39bad574cd26ecc7de552db033920797a709d78285dbb7940c4800a690133a06d239b618c9635ecde5c2e2367b65c651c SHA512 00571f5fc51ba97a5affd68efa419c47e8646e9cb0ae1d99f085b0a0032dcfcf42b58e4405b7143a7f4bf114b136013ad5e8e5a7986537439a3517a2fc3b98a0
+EBUILD lua_cliargs-3.0_p1.ebuild 912 BLAKE2B 1638e91d90020754defec1d85d589f95b54c6797893abd2e35a40eb8d58b787ba659cc60544e5379765f81f6d27648e9340e24e38a4b2ede2d03f34af4dc674a SHA512 e1bc9e132a2667f4ead85a9ed09f14ef0be5b5412e88ae2b692be700fefa4411ee4b9e5f28192ee9f5ea0aa1932fccefaf52a23ffc8e42d0ea5dda3f93f72877
+MISC metadata.xml 561 BLAKE2B a38b859e36bacd5481ca588a97d39f3353aedeae25b219c7b6e24353979c659407088e9ef16b71d642c19e26ff628f314ec0fab72ebd55a7fa42d0f0f32638d4 SHA512 da9b4c1e00524c0cc7963b0339a18f0b2fe254338269b8fc77e790ad26704ef92f450859838d7e0730cceda34ed34548c367659fae27302fba02252636537c59
diff --git a/dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild b/dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild
new file mode 100644
index 000000000000..703880029899
--- /dev/null
+++ b/dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+# Below is the upstream package version.
+# The final component of the version number has been mapped to the _px
+# component of the version number in portage so should be kept in sync.
+MY_PV="2.5-5"
+
+DESCRIPTION="A command-line argument parser."
+HOMEPAGE="https://github.com/amireh/lua_cliargs"
+SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins src/cliargs.lua
+ dodoc README.md
+dodoc -r examples
+ docinto html
+ dodoc -r doc/*
+}
diff --git a/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild b/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild
new file mode 100644
index 000000000000..4d1282f5bfa9
--- /dev/null
+++ b/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+# Below is the upstream package version.
+# The final component of the version number has been mapped to the _px
+# component of the version number in portage so should be kept in sync.
+MY_PV="3.0-1"
+
+DESCRIPTION="A command-line argument parser."
+HOMEPAGE="https://github.com/amireh/lua_cliargs"
+SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins -r src/cliargs.lua src/cliargs
+ dodoc README.md
+ dodoc -r examples
+ docinto html
+ dodoc -r doc/*
+}
diff --git a/dev-lua/lua_cliargs/metadata.xml b/dev-lua/lua_cliargs/metadata.xml
new file mode 100644
index 000000000000..61ea9ce51390
--- /dev/null
+++ b/dev-lua/lua_cliargs/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ This module adds support for accepting CLI
+ arguments easily using multiple notations and argument types.
+
+ cliargs allows you to define required, optional, and flag arguments.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">amireh/lua_cliargs</remote-id>
+ </upstream>
+</pkgmetadata>