summaryrefslogtreecommitdiff
path: root/dev-lua/lua_cliargs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lua/lua_cliargs
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lua/lua_cliargs')
-rw-r--r--dev-lua/lua_cliargs/Manifest6
-rw-r--r--dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild36
-rw-r--r--dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild36
-rw-r--r--dev-lua/lua_cliargs/metadata.xml17
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-lua/lua_cliargs/Manifest b/dev-lua/lua_cliargs/Manifest
new file mode 100644
index 000000000000..2b43581ef94a
--- /dev/null
+++ b/dev-lua/lua_cliargs/Manifest
@@ -0,0 +1,6 @@
+DIST lua_cliargs-2.5_p5.tar.gz 19513 SHA256 7b410dc3665b9bde5d954bfa73fb8254bfd5b4e72b20924f59006ce2f080baf4 SHA512 7c4d490f5d86b07bdf299c976b99bf83c9ba86fabeb321f348587f8ad207983292e3e9268ef72f3cc6ff9d6e32a43669de1d3c21c47499852f971c2cc2a4e746 WHIRLPOOL 07991c547513cc42d5596424651b4a119c30c5ff2dd7a1cabcd125a3198ceebf9f9d466f5110a684af2497cb48afff009aed922719c3115a34823481d194c53b
+DIST lua_cliargs-3.0_p1.tar.gz 29904 SHA256 35cbd5daff3411bdada1cd6f0cd5dcd61626da90f63f26483a0b9768d60dccad SHA512 2bdcd3c790a82351df598cb3d289de980fe771222ebd9715036678eecdbe51b7563d24629afa4d286b900d722bf844004d12f2330744a1e644d9286ac44b4dbe WHIRLPOOL 31b672caffa2dca31c92001c2ce3c482dd6411732547fbe5bdd27396868a8116d2b48e749ced352963d21adf83715473aca8796df13d12b09f99cc2833fda288
+EBUILD lua_cliargs-2.5_p5.ebuild 876 SHA256 bb2b1f820a8bd8b23633b7a9d8f734fa3b8512e8e8e10980456f8554371922a3 SHA512 00571f5fc51ba97a5affd68efa419c47e8646e9cb0ae1d99f085b0a0032dcfcf42b58e4405b7143a7f4bf114b136013ad5e8e5a7986537439a3517a2fc3b98a0 WHIRLPOOL 33912a2144bba01c9e9b5a70cc5e879335b35cb797be2870ebb8d60e519fc617ec0becbfede5e42d5947661e10f34f12fd669421bbd2fb140e8f891b47a990a2
+EBUILD lua_cliargs-3.0_p1.ebuild 895 SHA256 3f390e78216bc50c3f402ad9fcbac1e11118dd6f27ae50276cee2e6834718f4b SHA512 6b668eee3e7549f21ff3e5702446c57def75a98d6c3d3178bbe849a17f795366882a5675a9a065377f8fe74883049049cddd9c419849286ab1d1a20a8dd594b8 WHIRLPOOL 8b0b98bc6071861c7ddc16707f433737f620be6dc6beb351078320796d9cefaba215c486100b26f77bfdca2bee8dc72e51265300fb61de9cc75246305715700c
+MISC ChangeLog 1134 SHA256 365e7b9c431031a4ddf60130189eaacaf2c5554b5f23e76bc55587082054bfec SHA512 49f09a1d9e75012860d49cbc7dd001b634806f68294563685d8d641ef2493ec45d6c94e57ab01e4f63de36229537a368e9b91afbafebe0c12f4f605ad26b8f91 WHIRLPOOL 73d0ff5823678ec01e0d24dcaf05a02f394a978a62a47ede415f341c999aaa435e636d43fddc5efc260577d0fde43acc40592605f1180640c0a959a699af5d82
+MISC metadata.xml 561 SHA256 d5ae4baec36661f3bd6cc2af40f2a33227f9aeeaf229818dcf3001733e33b436 SHA512 da9b4c1e00524c0cc7963b0339a18f0b2fe254338269b8fc77e790ad26704ef92f450859838d7e0730cceda34ed34548c367659fae27302fba02252636537c59 WHIRLPOOL f4ebbde44f2aa0594e1dbd715591ad135c5877ce70d9a8cf658d19bb28845297bdbbc4a56a02210229e871580f422eeca57f16cb6db4a0bb990184c3fc847cf5
diff --git a/dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild b/dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild
new file mode 100644
index 000000000000..703880029899
--- /dev/null
+++ b/dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+# Below is the upstream package version.
+# The final component of the version number has been mapped to the _px
+# component of the version number in portage so should be kept in sync.
+MY_PV="2.5-5"
+
+DESCRIPTION="A command-line argument parser."
+HOMEPAGE="https://github.com/amireh/lua_cliargs"
+SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins src/cliargs.lua
+ dodoc README.md
+dodoc -r examples
+ docinto html
+ dodoc -r doc/*
+}
diff --git a/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild b/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild
new file mode 100644
index 000000000000..4a11763929bb
--- /dev/null
+++ b/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+# Below is the upstream package version.
+# The final component of the version number has been mapped to the _px
+# component of the version number in portage so should be kept in sync.
+MY_PV="3.0-1"
+
+DESCRIPTION="A command-line argument parser."
+HOMEPAGE="https://github.com/amireh/lua_cliargs"
+SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins -r src/cliargs.lua src/cliargs
+ dodoc README.md
+ dodoc -r examples
+ docinto html
+ dodoc -r doc/*
+}
diff --git a/dev-lua/lua_cliargs/metadata.xml b/dev-lua/lua_cliargs/metadata.xml
new file mode 100644
index 000000000000..61ea9ce51390
--- /dev/null
+++ b/dev-lua/lua_cliargs/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ This module adds support for accepting CLI
+ arguments easily using multiple notations and argument types.
+
+ cliargs allows you to define required, optional, and flag arguments.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">amireh/lua_cliargs</remote-id>
+ </upstream>
+</pkgmetadata>