summaryrefslogtreecommitdiff
path: root/dev-lua/lgi/lgi-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-lua/lgi/lgi-0.9.0.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-lua/lgi/lgi-0.9.0.ebuild')
-rw-r--r--dev-lua/lgi/lgi-0.9.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-lua/lgi/lgi-0.9.0.ebuild b/dev-lua/lgi/lgi-0.9.0.ebuild
deleted file mode 100644
index 51020ae52c96..000000000000
--- a/dev-lua/lgi/lgi-0.9.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-VIRTUALX_REQUIRED="manual"
-
-inherit eutils toolchain-funcs flag-o-matic virtualx
-
-DESCRIPTION="Lua bindings using gobject-introspection"
-HOMEPAGE="https://github.com/pavouk/lgi"
-SRC_URI="https://github.com/pavouk/lgi/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-lang/lua-5.1
- dev-libs/gobject-introspection
- dev-libs/glib
- virtual/libffi"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? (
- x11-libs/cairo[glib]
- x11-libs/gtk+[introspection]
- ${VIRTUALX_DEPEND}
- )"
-
-src_prepare() {
- sed -i \
- -e "s:^LUA_LIBDIR.*$:LUA_LIBDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua):" \
- -e "s:^LUA_SHAREDIR.*$:LUA_SHAREDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua):" \
- "${S}"/lgi/Makefile || die "sed failed"
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}"
-}
-
-src_test() {
- Xemake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}" check
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dohtml -r docs/*
- dodoc README.md
- if use examples; then
- dodoc -r samples
- fi
-}