summaryrefslogtreecommitdiff
path: root/dev-lua/busted/busted-2.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
commitca125edb1c8e51bd222fec61eb155151bbd4b791 (patch)
treeb1ca31e2662c41a1e85c62975d23ce38fa0e5df0 /dev-lua/busted/busted-2.1.1.ebuild
parent9d0673651c57438d51e18c6b8ca894d0491b2df3 (diff)
gentoo auto-resync : 25:08:2022 - 02:49:03
Diffstat (limited to 'dev-lua/busted/busted-2.1.1.ebuild')
-rw-r--r--dev-lua/busted/busted-2.1.1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-lua/busted/busted-2.1.1.ebuild b/dev-lua/busted/busted-2.1.1.ebuild
new file mode 100644
index 000000000000..ec99171efacc
--- /dev/null
+++ b/dev-lua/busted/busted-2.1.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua
+
+DESCRIPTION="Elegant Lua unit testing"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="
+ dev-lua/lua_cliargs[${LUA_USEDEP}]
+ dev-lua/luafilesystem[${LUA_USEDEP}]
+ dev-lua/luasystem[${LUA_USEDEP}]
+ dev-lua/dkjson[${LUA_USEDEP}]
+ dev-lua/say[${LUA_USEDEP}]
+ dev-lua/luassert[${LUA_USEDEP}]
+ dev-lua/lua-term[${LUA_USEDEP}]
+ dev-lua/penlight[${LUA_USEDEP}]
+ dev-lua/mediator_lua[${LUA_USEDEP}]
+ ${LUA_DEPS}
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-lua/busted
+ ${RDEPEND}
+ )
+"
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins -r busted
+}
+
+src_install() {
+ dobin bin/busted
+
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}