summaryrefslogtreecommitdiff
path: root/dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild')
-rw-r--r--dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild b/dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild
new file mode 100644
index 000000000000..66d3e88a1af1
--- /dev/null
+++ b/dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+inherit toolchain-funcs
+
+DESCRIPTION="Bit Operations Library for the Lua Programming Language"
+HOMEPAGE="http://bitop.luajit.org"
+SRC_URI="http://bitop.luajit.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~mips x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile()
+{
+ emake CC="$(tc-getCC)" INCLUDES= CCOPT=
+}
+
+src_install()
+{
+ exeinto "$(pkg-config --variable INSTALL_CMOD lua)"
+ doexe bit.so
+
+ dodoc README
+ dohtml -r doc/*
+}