summaryrefslogtreecommitdiff
path: root/dev-lisp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
commit12bb627384ddfd47382b9f1b6464481a58d01ebb (patch)
treef9760c04ccd4fcd7de214e2acd5b0e43fb530aa9 /dev-lisp
parent5fdd950c7ae03e12746a45c86d85861beaacc846 (diff)
gentoo resync : 29.08.2018
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/Manifest.gzbin3047 -> 3050 bytes
-rw-r--r--dev-lisp/cl-ppcre-unicode/Manifest2
-rw-r--r--dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0.ebuild26
-rw-r--r--dev-lisp/cl-ppcre/Manifest2
-rw-r--r--dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild30
5 files changed, 60 insertions, 0 deletions
diff --git a/dev-lisp/Manifest.gz b/dev-lisp/Manifest.gz
index 8861b60bef9e..0c9f5276b07c 100644
--- a/dev-lisp/Manifest.gz
+++ b/dev-lisp/Manifest.gz
Binary files differ
diff --git a/dev-lisp/cl-ppcre-unicode/Manifest b/dev-lisp/cl-ppcre-unicode/Manifest
index 319f01746f3d..58f5826c6186 100644
--- a/dev-lisp/cl-ppcre-unicode/Manifest
+++ b/dev-lisp/cl-ppcre-unicode/Manifest
@@ -1,3 +1,5 @@
DIST cl-ppcre-2.0.11.tar.gz 158418 BLAKE2B d65aa1a565dbe6c9d10e4dafe323ab1332929e46e00ea2e9775ad940ed5ac983520c0e423daa17bf0173420d2269b5af2fd9b52f8d3dbcb0c778e03e61ef052d SHA512 c693c568065c0571e5509599018e58951425a857cec3793312af0d22e248e32233f924eafc8ba67fbedad38cb3f4efa11343b785b073eaac53c31871422488b1
+DIST cl-ppcre-2.1.0.tar.gz 159051 BLAKE2B d1b9dd93c3f4c4c3a23a7c01f28cc4a8cc8543bfa3280f60b53d61dadb377f9e45c0f79592323bb7dcaf06721d899159f958f5b7d391370eeb5c6ede81a7a0cd SHA512 c9c95c58628fd5ecebf6e24e0c26913719360c325e90e78c256d1306eb8c2cbe85a2a5f617fdb6c2a7091bd80f4021ad0d294371b2696ad8e5873eca13aab866
EBUILD cl-ppcre-unicode-2.0.11.ebuild 639 BLAKE2B 85753d445f675c5b3d5be5360dbc63f68c3d03eda705ad2528342911ad815b0e2b4fe7b519b7c92b3e4c89443c635e61c2526ee28b1d1f25e08fc2bc3af5dd39 SHA512 2cd35a3f05ca5e96febb6886abce59229c65abf7b662b32deb8ed47f560606b6e6030a94bb9d19a2ebd43b6bbca1a989b78861dbaa2b82240c9f3162809bbe80
+EBUILD cl-ppcre-unicode-2.1.0.ebuild 641 BLAKE2B e977f0fa3a3237b507a0f773696a7179fd5ea62a6a4b2a6ccc4f1c23661dda84792836d4f6cb5ca8d24097233eae98e51fa92ae2a33d7464d37ce6d41cd5fc01 SHA512 e06ec96347dda45bd8ccd620a3558a9385cad620cf723484e7314970956c3904a3c710fcba888eb95883d67d4000965eabdecb780b1d9fb3e12f0000873e42fe
MISC metadata.xml 647 BLAKE2B d8bfd48db3b7e6b455bbfdb1aeba49c14c3d958ca17089165d18776fc7a18068fdd8080e85944ed57cdb5d9b15ec504511396046308452012551706060b06c8b SHA512 297e93b9bb8205c5729834dcb3f5686001f0f1aeedc1df83701c1350a853104463b37dc902013cd6cbaeddc1b83b1102f29ae55ab7b8f0ad98b6fccecef2ef28
diff --git a/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0.ebuild b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0.ebuild
new file mode 100644
index 000000000000..8203612b0edc
--- /dev/null
+++ b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
+HOMEPAGE="http://weitz.de/cl-ppcre/
+ http://www.cliki.net/cl-ppcre"
+SRC_URI="https://github.com/edicl/cl-ppcre/archive/v${PV}.tar.gz -> cl-ppcre-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lisp/cl-ppcre-${PV}
+ dev-lisp/cl-unicode"
+
+S="${WORKDIR}/cl-ppcre-${PV}"
+
+src_install() {
+ common-lisp-install-sources ${PN}/ test/unicode*
+ common-lisp-install-asdf ${PN}
+}
diff --git a/dev-lisp/cl-ppcre/Manifest b/dev-lisp/cl-ppcre/Manifest
index 41258222b4bd..66c492893744 100644
--- a/dev-lisp/cl-ppcre/Manifest
+++ b/dev-lisp/cl-ppcre/Manifest
@@ -1,3 +1,5 @@
DIST cl-ppcre-2.0.11.tar.gz 158418 BLAKE2B d65aa1a565dbe6c9d10e4dafe323ab1332929e46e00ea2e9775ad940ed5ac983520c0e423daa17bf0173420d2269b5af2fd9b52f8d3dbcb0c778e03e61ef052d SHA512 c693c568065c0571e5509599018e58951425a857cec3793312af0d22e248e32233f924eafc8ba67fbedad38cb3f4efa11343b785b073eaac53c31871422488b1
+DIST cl-ppcre-2.1.0.tar.gz 159051 BLAKE2B d1b9dd93c3f4c4c3a23a7c01f28cc4a8cc8543bfa3280f60b53d61dadb377f9e45c0f79592323bb7dcaf06721d899159f958f5b7d391370eeb5c6ede81a7a0cd SHA512 c9c95c58628fd5ecebf6e24e0c26913719360c325e90e78c256d1306eb8c2cbe85a2a5f617fdb6c2a7091bd80f4021ad0d294371b2696ad8e5873eca13aab866
EBUILD cl-ppcre-2.0.11.ebuild 714 BLAKE2B 6ac97f59ba11da102219ac54c28ef70b8880d0104296506c1f4fb348f508c9029d05dbfdf94a943c98e515dd13c6884f6b836812896f4d673c3bbe30473a99d8 SHA512 989a3f6dbf2468d8bf3dfb8e70a6189acd7fc63cee69bea26a81519d777a96b03d7722a2d9651f7cf82d1933dba1a5a912d0782bb520300dbc78e875caf551cc
+EBUILD cl-ppcre-2.1.0.ebuild 717 BLAKE2B 655377ddc98620bae830d3855130b9cd97b02c1e40810a4b8fa57573b81c10a37592032f3879a6b3272260f46529c29005aabd83dcbbb51546aced5f54540d3a SHA512 0432c0c205cd654fd96de60b8f2e2a9c6db847fbea3e2ca2173a3cf175544b4cc7beda3822ab4bcdca5ea604fa58a552cf8d7282d3124ade6902630d7a518aaf
MISC metadata.xml 1060 BLAKE2B 0cf37fa128f6a0d3995cee3f201206f60258ec3d9ceb57850880ab12d9b05671ae6061e7970784252bce9f340929dc59f3d48416c55069c8e9380e6bda38436f SHA512 fac4dca2369c4b636209e7406122b2dbb490a2ba35bd0d4e04ec58e6777f09ef5a1a0a4ddecb07beee2aa34a887e819acacac195c1a928ba6c1e06a7af7204b4
diff --git a/dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild b/dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild
new file mode 100644
index 000000000000..70c99953770f
--- /dev/null
+++ b/dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
+HOMEPAGE="http://weitz.de/cl-ppcre/
+ http://www.cliki.net/cl-ppcre"
+SRC_URI="https://github.com/edicl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lisp/flexi-streams"
+PDEPEND="dev-lisp/cl-ppcre-unicode"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+ rm -rf cl-ppcre-unicode test/unicode*
+}
+
+src_install() {
+ common-lisp-install-sources *.lisp test/
+ common-lisp-install-asdf ${PN}
+ dodoc CHANGELOG docs/index.html
+}