summaryrefslogtreecommitdiff
path: root/dev-lisp/trivial-gray-streams
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lisp/trivial-gray-streams
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lisp/trivial-gray-streams')
-rw-r--r--dev-lisp/trivial-gray-streams/Manifest4
-rw-r--r--dev-lisp/trivial-gray-streams/metadata.xml12
-rw-r--r--dev-lisp/trivial-gray-streams/trivial-gray-streams-20170830.ebuild17
-rw-r--r--dev-lisp/trivial-gray-streams/trivial-gray-streams-99999999.ebuild16
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-lisp/trivial-gray-streams/Manifest b/dev-lisp/trivial-gray-streams/Manifest
new file mode 100644
index 000000000000..d9fd9f319bd2
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/Manifest
@@ -0,0 +1,4 @@
+DIST trivial-gray-streams-20170830.tar.bz2 7520 BLAKE2B 2080b9ee30249c61c21f88663a247323afe2854c6444467d68fbdc42df9b8868cc49c305ab319ca88cf37ee8b0d423681c01174bb2a26d373a0c9427f2ad8e4e SHA512 4fbcfff5f2875daaf9c9bb286e2f753fccbb9840bb3c3593b9755204475aaf34241c1ffc2c93b5bf2c3428400e91082b01f15812eb51251afcabe9a57d5df3fa
+EBUILD trivial-gray-streams-20170830.ebuild 427 BLAKE2B 4c9d6f0fb8947010f7258d91dca5372b8f57e9a41d224e808949cb4383fc819ae6d8afbb3c3c012f7c62eef9b886698425fd1ca1cb6c297b25fbdf757210d483 SHA512 2dce2e1ae6fe587c3c73e8304c6237a42b4fe7b1c4186c2f1ceaff42c7e2bd395d9f82e2e2dc790cb0d783e0b69b7e136b94fd8c017688996e95cdd572e6bc14
+EBUILD trivial-gray-streams-99999999.ebuild 409 BLAKE2B 1c77e3dc48bcba51a2e3f142aa3c28d93424ee98a1743bae04ef44e3e03c7b078b496285c4c900106526eedd09738926e8db95d0566741cb3d85e6ff52c01fcb SHA512 193bb970f025012af66a890758ee862d0b97d03e558b9b19fd4b4378c51b1811e33f10690e88b7804927f500c31cd332a07eec6b96e13a8e631517f51630860f
+MISC metadata.xml 394 BLAKE2B 534576740809be806e39dd10ef1be5f5b2a3c44a511a4e2f2a92fca120e4c02d1430486ba6c5a0d50ac74e36fc6822275a5b8e063adcc4a3209d56ba217f8a35 SHA512 2aee230ee6fd936e5ba5d50c3e17e47aaa1dffc4cae7cddf2751ff331fe2191ad4c4e899aed7871ce90404c1b3e366282a9fcfaf928fea3dba8c159c64c6560f
diff --git a/dev-lisp/trivial-gray-streams/metadata.xml b/dev-lisp/trivial-gray-streams/metadata.xml
new file mode 100644
index 000000000000..53f2ee0bd5c2
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This system provides an extremely thin compatibility layer for
+ Gray streams
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-lisp/trivial-gray-streams/trivial-gray-streams-20170830.ebuild b/dev-lisp/trivial-gray-streams/trivial-gray-streams-20170830.ebuild
new file mode 100644
index 000000000000..63d5924ffdb0
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/trivial-gray-streams-20170830.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="A thin compatibility layer between Gray Stream Common Lisp implementations"
+HOMEPAGE="https://common-lisp.net/project/trivial-gray-streams/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="!dev-lisp/cl-${PN}"
diff --git a/dev-lisp/trivial-gray-streams/trivial-gray-streams-99999999.ebuild b/dev-lisp/trivial-gray-streams/trivial-gray-streams-99999999.ebuild
new file mode 100644
index 000000000000..9fa802eff228
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/trivial-gray-streams-99999999.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3 git-r3
+
+DESCRIPTION="A thin compatibility layer between Gray Stream Common Lisp implementations"
+HOMEPAGE="https://common-lisp.net/project/trivial-gray-streams/"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!dev-lisp/cl-${PN}"